Results 1 to 2 of 2
  1. #1
    RC poster
    Join Date
    Jul 2017
    Posts
    2

    E Revo 1/16 VXL - Electronics Issue ...

    Reposting in the right forum ....

    Here is the issue.
    I have ERevo 1/16 with stock motor, stock radio, 60A esc, 390 steering servo.
    When I connect to lipo 2s or 3s battery, everything powers on, controller, receiver, esc.
    1st Issue: I press throttle (forward), motor runs forward and stops but reversing the throttle on controller does not reverse motor and turning steering on controller does not turn - NO movement in steering servo.
    2nd Issue: I press reverse throttle and sometimes it reverses sometime it does not reverse. Still no steering movement at all.

    History: The set up was running fine, till kids ran it on grass and it stopped. I thought the battery needed changed. Put another 2S battery and it shuddered and smoked, unplugged immediately and then it sat for some time before I got time to fixing it up again.

    The motor seems fine.
    The radio receiver on the car seems fine (I have reset the controller already).
    I am thinking its either the esc or the steering servo.
    FYI, I have tried a different 60A esc which show same above mentioned issues and NO steering at all.

    Can anyone help me, put this beast back together?
    Is there anyway to check if the steering servo is good or bad?
    What are my options?
    Help

  2. #2
    RC Champion
    Join Date
    May 2002
    Location
    Midvale Utah
    Posts
    1,773
    If a second known good ESC showed the same symptoms then it is the steering servo. A bad steering servo can cause problems not related to the steering by overloading the BEC. Also whatever smokes needs to be replaced....
    Dacaur

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •