Results 1 to 4 of 4
  1. #1
    RC Competitor
    Join Date
    Aug 2016
    Location
    London
    Posts
    50

    Question Problems with traxxas 2085X servo!

    So I installed the Traxxas 2085X servo and I still have no steering!
    I see that link receiver blinks red and the ESC is not working properly, Itīs on Channel 1 and not sure whatīs happening!
    I bought a new servo because the other one stopped steering and after being opened was really in bad shape so I bought this one and I was thinking it was plug and play!
    Did the malfunction on the other one cause a problem in the link or ESC?
    Do I have to reset the link or ESC?

    thank you

  2. #2
    Marshal Double G's Avatar
    Join Date
    May 2008
    Posts
    13,670
    Plug the ESC into Ch1 and see if there is still a problem with that port. Plug the steering into Ch2 and see if the servo works. Try to figure where the problem is: receiver or servo.
    The Super Derecho

  3. #3
    RC Competitor
    Join Date
    Aug 2016
    Location
    London
    Posts
    50
    Quote Originally Posted by Double G View Post
    Plug the ESC into Ch1 and see if there is still a problem with that port. Plug the steering into Ch2 and see if the servo works. Try to figure where the problem is: receiver or servo.

    I think itīs the TSM receiver!
    can I reset this thing?
    The servo is new so what else?
    thanks

  4. #4
    RC poster
    Join Date
    Sep 2017
    Posts
    3
    just thinking, i had somewhat of the same problem .come to find out my receiver channel 1 and 2 were not working. if you have a spare try that, hope this helps ,yeh also make sure the receiver is not pulled apart .

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •