Results 1 to 18 of 18
  1. #1
    RC Qualifier
    Join Date
    Aug 2016
    Location
    Houston, Texas
    Posts
    607

    Car pulls to the left on hard acceleration



    Finally got her running and putting the 2650kv in instead of old 2200kv (4s batteries). I had it geared 27/50, but it was lifting one of the front wheels on acceleration, so I dropped it down the 24/50, but now it pulls hard to the left.
    I have the front diff spoiled, but the back is open, but not super loose. I packed it with marine grease. It seems like one of my right-rear wheel is pushing harder than the left and causing it to want to turn left.
    Am I still geared too tall, or am I missing something... any help would be greatly appreciated.
    Have a great day.


    Sent from my iPhone using Tapatalk

  2. #2
    RC Champion shack351's Avatar
    Join Date
    Dec 2016
    Location
    Kville
    Posts
    1,127
    Nice looking rig! I don't see how your gearing would be causing the problem. I have tried many, many gearing combos and never experienced that. What you're describing sounds like torque-steer. I used to use grease in my diffs but had some unusual results with it. I'm back on fluid in the diffs and all is well. Do you use TQi/TSM?

    -Shack

  3. #3
    RC Turnbuckle Jr.
    Join Date
    Feb 2002
    Posts
    9,352
    I know exactly what it is.... it is a traction issue

    Mine does it too. Tuning can help, but until your tires can all crab evenly, you can't get rid of it....

  4. #4
    RC Qualifier
    Join Date
    Aug 2016
    Location
    Houston, Texas
    Posts
    607
    Yeah, I did a bit more research and it's torque steer... I had a top-brace on before, but I need a part to put it back, so maybe that will help.
    I did the opposite of what they say, I tore the whole thing down and changed a whole bunch of things at once, so it could be anything... no worries, I can still bash around parking lots, but running on the track is scary with tight lanes and lots of brake/accel, so I just take it easy there


    Sent from my iPhone using Tapatalk

  5. #5
    RC Enthusiast
    Join Date
    Jan 2017
    Posts
    35
    You need to work with your suspension, you may need to change spring weights, possibly even differ the springs from side to side. Similar to a regular dirt track car. Maybe a sway bar set up would help, just a thought.

  6. #6
    RC Qualifier
    Join Date
    Aug 2016
    Location
    Houston, Texas
    Posts
    607
    thanks guys. hopefully i can get the sway bars and top brace over the holiday weekend, then mess around with the springs.

  7. #7
    RC Qualifier
    Join Date
    Aug 2016
    Location
    Houston, Texas
    Posts
    607
    I think I found one reason she pulls to the left. My servo is only 140oz/inch. Maybe it's just not strong enough to hold straight while the front wheel accelerates. Maybe I can find a good servo on Black Friday or cyber Monday, and drop this one in my 4tec2... it's a savox SC-1257TG


    Sent from my iPhone using Tapatalk

  8. #8
    RC Qualifier
    Join Date
    Aug 2016
    Location
    Houston, Texas
    Posts
    607
    Turns out that should be plenty torque, but it feels like I can turn the steering really easy. Think I might try putting in my tower pro cheapo. It seems like I only has torque twist with that servo.
    When I punch throttle on the bench, I can see the wheels turn left. Could it be I need a glitch buster?


    Sent from my iPhone using Tapatalk

  9. #9
    RC Turnbuckle Jr.
    Join Date
    Feb 2002
    Posts
    9,352
    that is the sign of a weak servo and possibly a brown out situation.... as for the hweels going left on the bench, they all do that, any vehicle

  10. #10
    RC Champion RazorRC22's Avatar
    Join Date
    Sep 2015
    Posts
    2,178
    Quote Originally Posted by SL4SHGT8BASHER View Post
    It seems like I only has torque twist with that servo.
    When I punch throttle on the bench, I can see the wheels turn left. Could it be I need a glitch buster?


    Sent from my iPhone using Tapatalk
    What ESC are you using? What’s the specs on the BEC? Savox servos tend to use a lot of power. Could be the issue if your BEC is weak.
    youtube.com/c/RazorRCvideos

  11. #11
    RC Qualifier Rich2's Avatar
    Join Date
    Feb 2014
    Location
    Western New York
    Posts
    627
    Quote Originally Posted by SL4SHGT8BASHER View Post
    Finally got her running and putting the 2650kv in instead of old 2200kv (4s batteries). I had it geared 27/50, but it was lifting one of the front wheels on acceleration, so I dropped it down the 24/50, but now it pulls hard to the left.
    I have the front diff spoiled, but the back is open, but not super loose. I packed it with marine grease. It seems like one of my right-rear wheel is pushing harder than the left and causing it to want to turn left.
    Am I still geared too tall, or am I missing something... any help would be greatly appreciated.
    Have a great day.


    Sent from my iPhone using Tapatalk
    Try taking the spool out of the front and put it in the rear. I don't think
    anyone runs a spool in front.
    Last edited by Rich2; 11-23-2017 at 05:47 PM.

  12. #12
    RC Qualifier
    Join Date
    Aug 2016
    Location
    Houston, Texas
    Posts
    607
    I'm running the mamba x. I should probably get an external BEC. I got the front spool idea from reading 1/10 tc forums. I could not find any info GT8 setups so I thought I would try it. I did not get as much tinker time as I thought I would get this long weekend. ��

  13. #13
    RC Qualifier
    Join Date
    Aug 2016
    Location
    Houston, Texas
    Posts
    607
    Learned from some of the local GT8e racers that front spools are illegal in roar racing, so I will be taking it out.


    Sent from my iPhone using Tapatalk

  14. #14
    RC Competitor
    Join Date
    Oct 2017
    Posts
    88
    Quote Originally Posted by SL4SHGT8BASHER View Post


    Finally got her running and putting the 2650kv in instead of old 2200kv (4s batteries). I had it geared 27/50, but it was lifting one of the front wheels on acceleration, so I dropped it down the 24/50, but now it pulls hard to the left.
    I have the front diff spoiled, but the back is open, but not super loose. I packed it with marine grease. It seems like one of my right-rear wheel is pushing harder than the left and causing it to want to turn left.
    Am I still geared too tall, or am I missing something... any help would be greatly appreciated.
    Have a great day.


    Sent from my iPhone using Tapatalk
    Off topic but you need to point me towards your build thread or at least provid more info/ photos on this build. I like what I see!

  15. #15
    RC Turnbuckle Jr. Squeegie's Avatar
    Join Date
    Jun 2014
    Location
    Southern California
    Posts
    7,545
    That is the Shining Star Chassis (SSC) chassis kit:
    https://www.teamsscrc.com/
    Creativity is intelligence having fun. -Einstein

  16. #16
    RC Qualifier
    Join Date
    Aug 2016
    Location
    Houston, Texas
    Posts
    607
    yes, and they are about to re-stock any day now. i am scrounging my pennies to scoop up another one.

    as for a build thread, i don't really have one, but i can snap a bunch of picks and post up some details about my baby-girl after work.

    cheers

  17. #17
    RC Competitor
    Join Date
    Oct 2017
    Posts
    88
    I’m waiting to get one of those chassis as well

    Looked into the STRC one as well and just got an email from the company that it’s discontinued

    Looking forward to some details sl4shgt8bashe

  18. #18
    RC Qualifier
    Join Date
    Aug 2016
    Location
    Houston, Texas
    Posts
    607
    i just posted it up in a new thread. let me know if you have any questions. i can take some more detailed photos if you need.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •