Results 1 to 13 of 13
  1. #1
    RC Enthusiast
    Join Date
    Jun 2017
    Posts
    43

    Does anyone knows the changes in the last firmware update?

    Hi,

    With the new Traxxas link app released two days ago I got two firmware updates
    one for the transmitter and one for the receiver .

    I there a way to get the changelog? The firmware version had major build version change.

    This is interesting.

    Have a great day,
    Tal.
    X-MAXX 8S

  2. #2
    RC Turnbuckle Jr. rag6's Avatar
    Join Date
    Mar 2008
    Location
    Accepting requests for bashing at GREENWOOD BASHPLEX in Pittsburgh PA!! Check the thread in the track buddy forum and reply there or pm
    Posts
    15,251
    Maybe it will fix the twitchy throttle issue and i can go back to using the app again 8)
    Ya can't polish fertilizer...

  3. #3
    RC Enthusiast
    Join Date
    Jun 2017
    Posts
    43
    what do you mean twitchy?
    X-MAXX 8S

  4. #4
    RC Turnbuckle Jr. rag6's Avatar
    Join Date
    Mar 2008
    Location
    Accepting requests for bashing at GREENWOOD BASHPLEX in Pittsburgh PA!! Check the thread in the track buddy forum and reply there or pm
    Posts
    15,251
    The same issue many are having with the stock esc. When coasting or at low throttle it twitches the brakes sporadically. I had to reset the tx to defaults and recalibrate the esc and not use the app to get it to stop. I believe the issue is in the link app...
    Ya can't polish fertilizer...

  5. #5
    RC Enthusiast
    Join Date
    Apr 2016
    Posts
    48
    There is a new update which includes the esc firmware update. Did someone check if it solved the brakes twitches issue?


    Sent from my iPhone using Tapatalk Pro

  6. #6
    RC poster
    Join Date
    Jun 2017
    Posts
    7
    Updated my Xmaxx today and it seems to be running faultlessly, no sudden braking at all. Top speed was up as well on 20/50 gearing.


    Sent from my iPhone using Tapatalk

  7. #7
    RC Enthusiast
    Join Date
    Apr 2016
    Posts
    48
    Sounds great. I have also made the update but haven’t had the time to test it. I have seen that now it can read the speed. Am I correct?


    Sent from my iPhone using Tapatalk Pro

  8. #8
    RC Racer
    Join Date
    Nov 2017
    Location
    Texas
    Posts
    163
    It always could calculate speed based on rpm etc. If it wasn’t before, then you may have had the app set to read the telemetry gps module instead of calculating based on the rpms sensor.


    Sent from my iPhone using Tapatalk
    Maxx 8S

  9. #9
    RC poster
    Join Date
    Dec 2017
    Posts
    15
    I did the update and it would lose throttle after a bit of use. Temperature was normal 110-130F range. I was not hitting it that hard. I believe this is more to prevent the fires than anything else. Which might be a good thing.

  10. #10
    RC Racer
    Join Date
    Nov 2017
    Location
    Texas
    Posts
    163
    Quote Originally Posted by highlander View Post
    I did the update and it would lose throttle after a bit of use. Temperature was normal 110-130F range. I was not hitting it that hard. I believe this is more to prevent the fires than anything else. Which might be a good thing.
    Was this on a V1 or V2 Max?


    Sent from my iPhone using Tapatalk
    Maxx 8S

  11. #11
    RC poster
    Join Date
    Dec 2017
    Posts
    15
    V2... and it went dead today....

    https://youtu.be/y7eb10790M8

  12. #12
    RC Turnbuckle Jr. rag6's Avatar
    Join Date
    Mar 2008
    Location
    Accepting requests for bashing at GREENWOOD BASHPLEX in Pittsburgh PA!! Check the thread in the track buddy forum and reply there or pm
    Posts
    15,251
    Seems many are having issues with the 8s esc dying while running in snow. I've been contemplating running in snow, but def not now. This cold snap sucks. Looks like temps might get near freezing on Sunday. I may have to get a parking lot run in then. It's 0° right now ... Can't wait for spring.
    Ya can't polish fertilizer...

  13. #13
    RC Champion NYbandit33's Avatar
    Join Date
    Mar 2011
    Location
    NY
    Posts
    1,153
    Mines been fine in the snow so far and it gets covered. I should get one of those chassis covers though
    Monster Baja Sla2h VXL
    Rustler VXL

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •