Results 1 to 4 of 4
  1. #1
    RC Racer
    Join Date
    Nov 2016
    Location
    Central WI
    Posts
    114

    TQI Link Android security update

    Just got my Link module back and the bluetooth connected almost instantly. Traxxas APP said I had a firmware update so I loaded it. Now no bluetooth connection. I can only assume that I need to send the unit back again?

    I would sure think that the minds at Traxxas would have engineered a protocol that disallowed loading of older version firmware, AND that all firmware after "x" date would have the security update included but this may not be the case.

  2. #2
    RC Enthusiast
    Join Date
    Jan 2018
    Location
    Iowa
    Posts
    20
    I'm guessing this problem hasn't been solved yet. I downloaded the app, but I haven't connected my controller or truck yet. Is this a good feature or should I just uninstall the app until they get it fixed? How did it go for you?

  3. #3
    RC Racer
    Join Date
    Sep 2017
    Posts
    103
    Quote Originally Posted by Nemisis View Post
    I'm guessing this problem hasn't been solved yet. I downloaded the app, but I haven't connected my controller or truck yet. Is this a good feature or should I just uninstall the app until they get it fixed? How did it go for you?
    Don’t do the update! It’ll only cause more issues than any support.

  4. #4
    RC Turnbuckle Jr.
    Join Date
    Feb 2002
    Posts
    9,311
    not sure why you are having issues? I originally had to get my module re-flashed by traxxas, and since getting it back, haven't had furhter issues, have the msot curent version of the app, and firmware installed

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •