Results 1 to 3 of 3
  1. #1
    RC poster
    Join Date
    Jan 2018
    Posts
    2

    Slasher Vxl 3 with onboard audio.

    Just got Mike Jenkins edition slasher vxl. Trying to set it up to run. Appear I have done everything right and bought the dual charger. I am using nimh right now as I am new to this.
    I paid the controller with vehicle and go throttle on one blink then reverse on two blinks then the DSC goes to flashing green and I release.
    After release it flashes a steady red and when I pull trigger itís a short spurt of power and then it stops. Nothing else.

    Any help here? Steering still works just no forward or backward and light flashes red.
    Am I missing something on set up?

  2. #2
    RC poster
    Join Date
    Jul 2011
    Location
    Wylie, TX
    Posts
    3
    Quote Originally Posted by Bryanshel View Post
    Just got Mike Jenkins edition slasher vxl. Trying to set it up to run. Appear I have done everything right and bought the dual charger. I am using nimh right now as I am new to this.
    I paid the controller with vehicle and go throttle on one blink then reverse on two blinks then the DSC goes to flashing green and I release.
    After release it flashes a steady red and when I pull trigger itís a short spurt of power and then it stops. Nothing else.

    Any help here? Steering still works just no forward or backward and light flashes red.
    Am I missing something on set up?
    It sounds like your speed control has Low-Voltage Detection turned on and it should be off since you are not run lipo batteries.

  3. #3
    RC Turnbuckle Jr. Petertje60's Avatar
    Join Date
    Jan 2011
    Location
    Rotterdam, Netherlands
    Posts
    8,572
    Pretty sure that JTGixxer nailed it. Besides that, there is a forum for the 1/16 E-Revo and Slash, look here.
    Nobody is born with experience

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •