Results 1 to 11 of 11
  1. #1
    RC poster
    Join Date
    Dec 2017
    Posts
    14

    No throttle or steering

    Good day everyone, I have gotten an erevo brushless vxl as a swap. It has the velineon motor and Traxxas vxl3m esc. Have put in new 2s lipo charged. The receiver has green led, the esc has solid green led when on also. Transmitter is binded and on, have rebinded the transmitter to the receiver twice.
    When you turn wheel on transmitter, either way there is no movement on the car. The throttle trigger also does nothing.
    Have tried another Traxxas transmitter from my stampede and rebinded to erevo and exactl same problem no steering or throttle??
    Any suggestions since I am pretty new to the hobby. I have added some parts like bumpers, changed over shocks and painted a new shell. Haven't had this type of problem yet.

    A funny thing I have noticed, is that the steering trim knob, when you turn it fully either way I am getting the back tyres spinning very quickly back and front. Can't get anything on the front either steering or drive on tyres.

    Any help would be appreciated since I don't know what to test next.
    Thankyou

  2. #2
    RC Qualifier
    Join Date
    Dec 2017
    Location
    Van. Island British Columbia
    Posts
    698
    Have you tried doing a factory reset on your transmitter. Not sure if you know how or have ever done one and see if that makes it work you can check support video's at the top.
    I would pop the top off my receiver and make sure all the plugs are in the correct places 1 to turn 2 to burn.
    One other because i don't know is if the transmitter came with the vehicle or not is when you take the cover off the receiver check the number and see if it corresponds to the number on the transmitter and see if their compatible.

  3. #3
    RC poster
    Join Date
    Dec 2017
    Posts
    14
    Good day, just an update. I reset the transmitter from some instructions off the Internet and rebound the transmitter and receiver and still no luck. I checked the cable connections on the receiver and found that they were reversed. The erevo now had throttle and steering. Thankyou very much for the suggestions.

    New problem the centre front is missing a part and only rear wheels drive. I found the missing part in my spare parts bin. But I have no idea how to install. Looking at exploded view diagram can see where it goes but no way of fitting it in such a tight spot. Undone the bottom kick plate, and could see the place but the part can't fit in.
    Thankyou

  4. #4
    RC Qualifier
    Join Date
    Dec 2017
    Location
    Van. Island British Columbia
    Posts
    698
    On mine i have to loosen the 4 transmition screws at least 1/2 way out to connect my drive shaft, give that a try or you might have to take them right out and connect the shafts then slide it back in.
    If you run into problems you can pm me. You shouldn't have to take the back shaft off to do this. Make sure you connect the front diff first.
    Last edited by Rain Dawg; 01-14-2018 at 04:33 AM.

  5. #5
    RC poster
    Join Date
    Dec 2017
    Posts
    14
    Hi I have added 2 photos of the underside which I am trying to install the part
    http://i50.photobucket.com/albums/f3...pswnen1fhb.jpg

    http://i50.photobucket.com/albums/f3...ps6umff8tj.jpg

    The bottom has been removed but I can't fit the part in. There isn't any free space to weave the part in.

  6. #6
    RC Qualifier
    Join Date
    Dec 2017
    Location
    Van. Island British Columbia
    Posts
    698
    Ok then you will have to remove the screw out of the steering post that's in the way and you should be good to go. Let me know if this doesn't work. Is it possible to push the trans out of the way without removing the steering post or it might be easier to take the rear shaft off. I think i'd go for removing rear shaft and push trany out of the way.I think you will still have a heck of a time connecting to the diff with the steering post in the way.
    Last edited by Rain Dawg; 01-14-2018 at 05:01 AM.

  7. #7
    RC poster
    Join Date
    Dec 2017
    Posts
    14
    Thanks will try tomorrow since spent so many hours today on this erevo. I am playing with the kids and will have another look at it tomorrow after work. Will report back once I have had a crack at it. Would dismantling the entire front end make it to easier? If so are there instructions on how to install this part made for beginners....

  8. #8
    RC Qualifier
    Join Date
    Dec 2017
    Location
    Van. Island British Columbia
    Posts
    698
    You tube shows a guy doing exactly what your doing called Little mans revo front center drive shaft mod and he removed the steering post and removed the c-clip of the u-joint slid the pieces in and then put the u-joint back together again looks pretty straight forward. The guy on vid is Roy Nelson if this helps.

  9. #9
    RC poster
    Join Date
    Dec 2017
    Posts
    14
    Ok will have a look at video and look at the revo tomorrow with a fresh set of eyes. It might look straight toward tomorrow after checking out the video you suggested.
    Thanks for the help and suggestions it is very much appreciated

  10. #10
    RC poster
    Join Date
    Dec 2017
    Posts
    14
    Just an update, got the part in after a bit of YouTube viewing. Have run it at the park and the Merv flies. Thankyou for everyone who helped and offered suggestions.

  11. #11
    RC poster
    Join Date
    Feb 2019
    Posts
    14
    I have the same issue on my slash I have done all of the above re-set , re bind and still nothing !!! Seems to be on going issue with Traxxas products faulty crappy moto just buy a new part we fix anything

    Have a nice day

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •