Results 1 to 3 of 3
  1. #1
    RC poster
    Join Date
    Mar 2018
    Posts
    1

    Question Front Wheels are Getting way more power than Back wheels.

    My pretty much stock summit 1/10 scale has an immense amount of wheelspin in the front wheels but the rear wheels dont get as much power. This sadly results in not being able to use 2x 2s lipos because the front gets so much wheelspin that as it launches it spins out right away. So I am using the stock 3000 mah 7 cell nimh batteries. I also can't do wheelies cause if tryed the front wheels just spin. If I lift the rear wheels the summit will start to move but if i lift up the front wheels absoulutely nothing. Any suggestions on what to do or what the problem is?
    Last edited by MSS2006; 03-25-2018 at 07:54 PM.

  2. #2
    RC Competitor
    Join Date
    May 2015
    Location
    WA state
    Posts
    78
    Start at the wheels hubs and work your way in from there. If the axles are spinning on the inner wheels that could cause it. Could be the shafts broken or anything in that area. From there go to the diffs if everything looks good.


    Sent from my iPhone using Tapatalk

  3. #3
    RC Turnbuckle Jr. jamann's Avatar
    Join Date
    Sep 2009
    Location
    Victoria B.C Canada
    Posts
    5,673
    Check your rear drive shaft it may be damaged and the splines are slipping
    Giving you some power until the load overpowers it

    Mountains can't stop me they have tried
    Mountains cant stop me
    they have tried

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •