Results 1 to 4 of 4
  1. #1
    RC poster
    Join Date
    Apr 2018
    Location
    In sacremento
    Posts
    15

    Slash running problems

    Hey guys I have a newer nitro slash with the stock 3.3 engine. My problem comes when the car doesnít stay running. I had this problem before but then fixed by Putting in a new glow plug tunning it and cleaned the muffler. It ran better than ever it then ran dry of fuel and I put it away for the day. The next day I was exited to drive it concedering it had not been running for a couple weeks. When I attempted to start the car it was not running but was getting fuel so as a soultion I changed the glow plug. Now I donít now if this is note worthy or not but the little coiled fialament was pushed to the very back of the glow plug but it stilled glowed. So I put in a new glow plug and it fired back up. I went to drive and it died. To my surprise it was doing the same thing as before it would start idle die start idle die and it didnít matter how much throttle I gave it but it kept dieing. So I did what I did before but it still would not run. So I gave up for the night. I know you guys are smart so if anyone knows what is wrong it would help a bunch. Thanks.

  2. #2
    Marshal Double G's Avatar
    Join Date
    May 2008
    Posts
    13,559
    Pull the head and see if there is anything dancing around in the cylinder.

    Also, if it has been a while since you ran it last, there is the possibility that the leftover fuel is gumming up the system and would require a tear down and cleaning.
    The Super Derecho

  3. #3
    RC poster
    Join Date
    Apr 2018
    Location
    In sacremento
    Posts
    15
    Thanks I will try that

  4. #4
    RC poster
    Join Date
    Apr 2018
    Location
    In sacremento
    Posts
    15
    Tried both nothing loose and still won’t run any other ideas

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •