Results 1 to 17 of 17
  1. #1
    RC poster
    Join Date
    May 2018
    Posts
    4

    EZ Peak Storage Charge Mode ??

    Just got a new EZ Peak single output charger and an Id 2S 5800 Lipo pack, quick question about the storage mode charge setting. The other night I charged the pack up about 3/4 charge (that's all I had time to let it charge), then only got to run my 4tec 2.0 for about 5 or 6 minutes so I know I didn't run the pack down very far in its charge. Since I won't be able to run the car for a week or 2 I put the pack on storage charge mode, a full 2 hours later it was only up to the second LED on the charge duration and since I had to leave I had to shut it down. Why would it take well over 2 hours (possibly 3-4 hours) to charge (or discharge) on storage mode?? Even at a 4 amp rate?? Just curious...

  2. #2
    RC Qualifier
    Join Date
    Jun 2016
    Location
    North Jersey
    Posts
    657
    Can't give you the tech answer, but that sounds totally normal.

  3. #3
    RC Champion FnFancy's Avatar
    Join Date
    May 2016
    Location
    Los Al California
    Posts
    1,658
    It takes alot longer to discharge a battery than charge a battery with the ezpeak. Fear not, it should only take about an hour to fully charge the battery. Discharging is a different story, you'll want to either drive the car some more or put it back on the storage charge so you don't kill the battery.

    it's alright son, I'll fix it
    Its alright son I'll fix it when you break it

  4. #4
    RC Qualifier
    Join Date
    Nov 2016
    Location
    Atlanta, Georgia
    Posts
    943
    My fully charged 6400 onyx 3s used in my old slash 4x4 I had discharged using the charger from full capacity and it took about 18 hours. I honestly don’t recommend the feature because after doing this again a few months later it actually discharged my battery to a point where the charger would no longer accept it as it was under voltage

  5. #5
    RC poster
    Join Date
    May 2018
    Posts
    4
    Thanks for the replies, i figured it was ok but i didn't want to take a chance ruining the pack just in case. I'm not new to lipo's, i have a bunch of 2S and 3S set's that i use in my R/C boats and charge with an Onyx charger, i'm used to seeing the voltage read-out of each cell during their charge cycle. The Onyx doesn't have discharge feature however. With the boats, a 5-6 minute run time is normal and takes the packs right down to the LVC, then i just bring them back up to about half charge for storage (going by the voltage read-out). Even tho i dabbled with R/C cars years ago, i'm definitely a newbie to the R/C car world!
    Last edited by Double G; 06-28-2018 at 07:47 AM. Reason: banned battery name

  6. #6
    RC Racer
    Join Date
    Dec 2017
    Location
    Wilmington,nc
    Posts
    129
    Yeah just be patient,,,it’s worth the wait vs doing harm to you or the battery,,,,it’s an excellent unit and sooooo easy to use......have a blast......tazzzz

  7. #7
    RC Qualifier
    Join Date
    Apr 2018
    Posts
    841
    Cells may need to balance as well as the amperage being only 1a max if memory serves me right. It takes a while for this to happen if you have a decently large battery. Totally normal and nothing to be alarmed at

  8. #8
    RC Qualifier lotust251's Avatar
    Join Date
    Mar 2017
    Location
    Long Island NY
    Posts
    280
    yes if you try to use the store mode on a traxxas charger with a near fully charged lipo it will take hours on larger batteries.
    Slash, Stampede,Craniac,X2 TRX4 ,ford gt 4 tec 2.0

  9. #9
    RC poster
    Join Date
    Dec 2018
    Location
    Boston, MA
    Posts
    3
    Funny I was just about to start a thread on this very subject. I recently just got back into RC's but had never used lipo's before. I have the EZ Peak Live and two 3s 5000 packs. I've done some reading on them and saw that you're not supposed to let fully charged lipo's sit unused for extended periods of time. Anywho, my packs were fully charged today but I realized I wasn't going to be using them for a few days so I storage charged them. It must have taken at least 6 hours for the two. Glad to know that's normal. They've got to be joking when they say not to leave them unattended while charging lol.

  10. #10
    RC Racer
    Join Date
    Nov 2018
    Location
    See Above.
    Posts
    115
    Quote Originally Posted by EREVO41 View Post
    Funny I was just about to start a thread on this very subject. I recently just got back into RC's but had never used lipo's before. I have the EZ Peak Live and two 3s 5000 packs. I've done some reading on them and saw that you're not supposed to let fully charged lipo's sit unused for extended periods of time. Anywho, my packs were fully charged today but I realized I wasn't going to be using them for a few days so I storage charged them. It must have taken at least 6 hours for the two. Glad to know that's normal. They've got to be joking when they say not to leave them unattended while charging lol.
    There not joking.. things can happen when batterys charge.. go watch some youtube videos of charging gone wrong . . . good way to loose your house.


    And discharge the battery in your rc car or something down to LVC then put it on the charger for storage won't take much more then a 1/2 hour or so.


  11. #11
    Marshal Double G's Avatar
    Join Date
    May 2008
    Posts
    13,495
    With a discharge current of only 665mAh (750 for the dual) I can see it taking so long to do so.
    The Super Derecho

  12. #12
    RC poster
    Join Date
    Dec 2018
    Location
    Boston, MA
    Posts
    3

    EZ Peak Storage Charge Mode ??

    Quote Originally Posted by TraverseCityMi View Post
    There not joking.. things can happen when batterys charge.. go watch some youtube videos of charging gone wrong . . . good way to loose your house.


    And discharge the battery in your rc car or something down to LVC then put it on the charger for storage won't take much more then a 1/2 hour or so.

    I bought a Lipo bag to charge it in. I was charging it in the house, but after doing some reading I'm charging in the garage now. I just don't wanna stand down there in the cold staring at it for hours.

    Traxxas has a strict language policy. A word filter operates to change inappropriate words to *s. When you see these in your post, you MUST edit them out. -ksb51rl
    Last edited by ksb51rl; 01-09-2019 at 08:04 PM.

  13. #13
    RC Qualifier Panther6834's Avatar
    Join Date
    Jan 2019
    Location
    SF Bay Area
    Posts
    671
    Unfortunately for me, I don't have a garage. I live in a condo (thankfully, ground floor of 2-level building), and the closest we have are carports. While there is an enclosed patio, and an outdoor double-outlet, it (also unfortunately) doesn't work. As such, I have no choice but to charged my LiPos (for Rustler, as well as for Typhoon H drive) inside. I used to charge them on the kitchen counter (engineered granite), but my wife started getting irritated...so I switched to charging them on the guest bathroom counter (engineered marble). Not sure if the bathroom is any better than the kitchen, but at least my wife stopped complaining, which saves me a few headaches each month.

    Sent from my SM-N960U1 using Tapatalk
    ~ Love, laughter & kindness makes the world better

  14. #14
    RC poster
    Join Date
    Jul 2019
    Posts
    2
    I'm new to the lipo batteries and chargers and am using the Traxxas Ez Peak. After chaging then using the battery I'm not planning to use it untill the next weekend. I've put the bettery on the charger and put onto store mode and pressed start. Is it normal for the LEDs to light up the same as if it were charging? The LEDs lit up from 1a 2a 3a 4a untill the audible sound alerted me. Is this correct for storring the battery?

  15. #15
    RC Qualifier
    Join Date
    Jun 2016
    Location
    North Jersey
    Posts
    657
    Quote Originally Posted by T8R View Post
    I'm new to the lipo batteries and chargers and am using the Traxxas Ez Peak. After chaging then using the battery I'm not planning to use it untill the next weekend. I've put the bettery on the charger and put onto store mode and pressed start. Is it normal for the LEDs to light up the same as if it were charging? The LEDs lit up from 1a 2a 3a 4a untill the audible sound alerted me. Is this correct for storring the battery?
    Yes. You are fine.

  16. #16
    RC poster
    Join Date
    Jul 2019
    Posts
    2

    Thumbs up

    Quote Originally Posted by Blown94 View Post
    Yes. You are fine.
    Thanks that's a relief, I didn't feel like having my hoise burnt down.

  17. #17
    RC poster
    Join Date
    Jul 2019
    Posts
    1
    Great info. guys. Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •