Results 1 to 4 of 4
  1. #1
    RC poster
    Join Date
    Dec 2015
    Posts
    5

    Unhappy HELP! alias takes off, emits 3 beeps and then disconnects and falls

    Hey guys,

    As title says I sync my alias, take off and then almost immediately I hear 3 beeps before it falls. Lights blinking on the alias tells me that it seems to disconnect right after takeoff. Once I disconnect and reconnect the Alias battery it syncs again, then I take off and it desyncs again.

    Have tried factory reset of the joypad, calibrating, syncing procedures etc. Im not clicking left stick button either. At a loss, wondering if anyone has any insight or experience with similar issues?

    Thanks!

  2. #2
    Traxxas Marshal
    Join Date
    Mar 2003
    Location
    Wherever the road takes me.
    Posts
    37,728
    Have you tried calling Traxxas about this yet? I'm sure they have a step-by-step trouble shooting process for issues like this.

    1-888-TRAXXAS
    "Happiness depends upon ourselves." -Aristotle

  3. #3
    RC poster
    Join Date
    Dec 2015
    Posts
    5
    Nope but that's definitely my next step. Thanks man.

  4. #4
    Traxxas Marshal
    Join Date
    Mar 2003
    Location
    Wherever the road takes me.
    Posts
    37,728
    You're welcome, I hope it helps. Traxxas has great customer support.
    "Happiness depends upon ourselves." -Aristotle

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •