Results 1 to 4 of 4
  1. #1
    RC poster
    Join Date
    Apr 2018
    In sacremento

    Controller issues

    I Have a year old nitro slash. My issue is that my controller wonít control the car. It worked fine and I started it and i had no control. I have tried changing the batteryís and that did not help. Things got interesting when I tried to bind the reciver and transmitter again. Now I donít have much experience with theses receivers and transmitters but I know how to bind them. Once I have done the procedure both lights flash red as expected. But they stay that way for five minutes and then the car begins to flash red rapidly and they never bind. When I turn them on normally transmitter then the receiver both lights are green but there is still no response. Iíve checked the servos and the wires and they look fine. If this helps at all I did bring it to a short course track so the last time it ran it was very bumpy and experienced challenging terrain. If you guys have any idea whatís wrong I would love your opinion or even just your best guess. Thank you 😊

  2. #2
    RC Qualifier westoakmech's Avatar
    Join Date
    Dec 2011
    I would check the antenna wire and make sure that it did not get cut.
    Unplug your servos one at a time and see if that does anything, I have had a steering servo go bad, and make the whole thing not work.
    If you look in the manual it should walk you through the binding, and there should be a calibration. It may only be for the throttle though.
    If you have another car, try and bind that receiver to that transmitter , and vice versa. That would help eliminate one or the other.
    I would be leaning towards the receiver being bad. I have never had a transmitter problem
    Rusty 2.5R,T-max 2.5 & 3.3,Summit VXL Nitro 4-tec

  3. #3
    RC Champion
    Join Date
    Apr 2018
    You may have to reset your forward and reverse/brake by pulling the trigger and releasing when the lights blink accordingly then push it forward as if you had reverse/brake. Not sure itís the exact issue, but sounds like it could be. Hope you get it resolved.

  4. #4
    RC Qualifier Rich2's Avatar
    Join Date
    Feb 2014
    Western New York
    Sounds to me like your throttle trim may have inadvertently moved to one end or the other.
    You might try resetting your transmitter to default. You could also try moving your multifunction
    nobb to where it was when you last used it if you remember or at least try different positions.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts