Results 1 to 2 of 2

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    RC Competitor
    Join Date
    Mar 2015
    Location
    Finland
    Posts
    88

    Question Some newbie questions.

    So i am completly new to boating and got myself an M41 and got some questions about the boat. I have run it a couple of times and after the first 2 runs there was some brown liquid coming from the near the prop and after about 5 runs i noticed the bottom is not completly flat. I have flipped tve boat 2 times at high speed but thats about it that could have messed up the hull. I got some 3s 5000mah traxxas lipos and after the first run my charger showed that it charged 5020mah and i do have the lipo cut off on so thats wierd. Also when the lipo cut off cuts off the led on the esc doesnt change color like on the most esc's.

    http://imgur.com/a/xTl28MJ

  2. #2
    RC Qualifier
    Join Date
    Feb 2012
    Location
    Mount Real, Canada
    Posts
    648
    1. That brown color is the Factory Lubricant from Traxxas which we called Grease, on the packaging of your boat all comes together with it. Remember to use only a marine type grease which is color blue to easily identify.
    2. The Brass Tube which is close to the props needs to Lubricate Every 3-4 runs, If your talking about the Brass Tube is not flat, it is because built to be like that because of the cavitation on the water, so that it wont go in and it will only stay halfway if this is your exact question.
    3. Are you using the Traxxas ID Charger or another Brand?
    Sharing is the best thing to do on EARTH legally.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •