Results 1 to 6 of 6

Threaded View

Previous Post Previous Post   Next Post Next Post
  1. #1
    RC poster
    Join Date
    Jul 2018
    Location
    Amory, Ms
    Posts
    11

    Steering quit working out of nowhere

    Need some input! Finally got my son's Slayer tuned where she is snappy as and idling like a champ! Steering servo was working 10sec before we went outside setting to and camber on kitchen table. Go outside and it fires faster than any RC I have had (Savage is pull start and usually takes 3 pulls) brought idle down a little then waited for low jet adjustment to clear, punch it to check for bog, there is zero! Guess what else there is zero of? Steering! Tried the remote for my HPI which is a much higher end remote that all digital but still should have worked. The disappointment ton his face almost killed me! Not to mention I was up till 5am putting a sway bar kit, spool, and what I thought would be 1 lower A arm, then I noticed the new ones where like 15mm wider a side so I had to change the whole front end and reset everything!

    Where would you guys start I want to fix it with one order because I don't have a local hobby shop so basically I'm going to order everything it could be that way it's going to be fixed regardless I was going to order a new remote a new processor for the truck where all the servos plug-in(even though I pulled the steering servo out and put it in an open Channel then switched it on the remote and it didn't do which leads me to believe the remote took a crap I just don't know how common it is for the steering to go out) I guess a new steering servo too and that's all I can think of maybe a new set of crystals too? any opinions and all opinions are more than welcome I'm tired of seeing my little man disappointed Thanks in advance!!!!!
    Last edited by Double G; 07-07-2018 at 06:30 PM. Reason: language

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •