Results 1 to 5 of 5

Thread: Ez start

  1. #1
    RC Enthusiast
    Join Date
    Jan 2018
    Posts
    20

    Angry Ez start

    My ez start has stopped working but have replaced with a new one. The new one spins when I put the battery pack on but it doesn’t make the engine turn over am I missing something please help thanks

  2. #2
    RC Champion olds97_lss's Avatar
    Join Date
    Dec 2003
    Location
    Dekalb, IL
    Posts
    2,347
    Makes the engine spin but not start?
    Expert rigging at it's best!

  3. #3
    RC Enthusiast
    Join Date
    Jan 2018
    Posts
    20
    When the ez start if off I can turn the shaft and the engine crank but when I put the ez start on it makes the ez spin and make a noise but doesn’t turn the shaft over to crank the engine

  4. #4
    RC Qualifier IndyBama's Avatar
    Join Date
    Jun 2017
    Location
    Bama
    Posts
    468
    Sounds to me either ur OWB is in backwards or the ez start has striped a gear

    Sent from my SM-J327VPP using Tapatalk

  5. #5
    Marshal Double G's Avatar
    Join Date
    May 2008
    Posts
    13,498
    Did you replace the wand or the starter on the back of the engine? If the latter, make sure the letters on the one-way bearing (OWB) face the engine and the washer is installed between the back plate and OWB.
    The Super Derecho

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •