Results 1 to 11 of 11

Threaded View

Previous Post Previous Post   Next Post Next Post
  1. #1
    RC poster
    Join Date
    Jun 2018
    Posts
    11

    Titan 550 12T motor

    I'm new to RC. I have a 2wd electric Rustler with the stock Titan 550 12T motor. I burnt out my original and traxxas was awesome and sent me a replacement. I could explain more, but maybe I'll get right to the motor problems.

    With the new motor, I used the water trick to break it in. Ran it in a jar of water for a bit on low power. Dried it off with engine cleaner and spun it dry. Then, I ran it 3 times in child mode (1/2 power) and I kept a slow pace driving figure 8s on smooth cement. Babied it. On the 4th battery pack I ran it in pro mode making some high speed runs. I bash it pretty good in the dirt and I jump it a lot.

    It's starting to make strange noises, a screeching noise. Drive shafts seem to be moving smoothly. The motor seems to inhale a bunch of dirt/sand when I'm off roading. I'm pretty much off road all the time. I've cleaned the motor after hearing noises. Stops it for just a bit, but then same stuff. I've noticed when all electronic are off, I can push car forward accros floor forward. It won't roll backwards. The motor seems to be slower. It drives in forward and reverse.

    There is a small amount of side to side play in the motor spindle. It may he effecting my slipper gear. I have not ruled out that this noise is from slipper gear.

    How durable are these motors? I plan to bash pretty hard. The body has upgrades to take a beating. This is my second motor in 3 weeks

    Any advice or input will be appreciated

    Last edited by Double G; 07-07-2018 at 06:37 PM. Reason: merge

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •