Results 1 to 11 of 11
  1. #1
    RC Competitor
    Join Date
    Jul 2018
    Posts
    90

    UDR Servo problem...

    Hello all,

    I Just receive my UDR a few days ago and immediately swapped out the stock 2075X with a Savox 1256TG. The problem is that I'm getting servo twitching and creep with the Savox when the TSM is on. Doesn't seem to matter how much TSM is applied. With TSM off, the Savox behaves normally. I put the 2075X back in and verified that it works fine with TSM on or off. Of course the 2075X is not reliable so keeping it is not preferred.

    What do you all think? I have a Glitch Buster on order.

  2. #2
    RC Racer
    Join Date
    Apr 2017
    Posts
    161
    I installed a savox 1268 and no glitch buster and havenít had any problems. Everyone says you need one if you run a savox and I am currently running 1258ís in 3 other cars and a couple of the waterproof ones in my crawlers and have never needed one.


    Sent from my iPhone using Tapatalk

  3. #3
    RC Enthusiast
    Join Date
    Apr 2018
    Posts
    20
    Hey Tyro, I got the 1256TG after the 2075x went kaput on my 3rd run.

    I have no issue with it. Louder than the stock on but all is fine. Didn't put a glitch buster in the mix as well...

  4. #4
    RC Racer
    Join Date
    Apr 2017
    Posts
    161
    So I spoke to soon, about half way through my second battery it started twitching and was slow to center. It did it one other time before it went dead but why it started after running it trouble free for the last couple weeks I donít know. Iím assuming a glitch buster will fix it.


    Sent from my iPhone using Tapatalk

  5. #5
    RC Competitor
    Join Date
    Jul 2018
    Posts
    90
    Firstly, thank-you guys for your reply's. I'm hoping others will advise on this issue. I spoke with Traxxas support and they said it sounded like interference of some type and suggested:
    1. Install a glitch buster
    2. Find a ferrite bead and wrap the servo lead around it to reduce EMI
    3. Replace the Savox servo because it isn't compatible. (Sigh)

  6. #6
    RC Competitor
    Join Date
    Jun 2018
    Posts
    63
    It does sound like interference - but quite a few use Savox servos. Maybe it's the model Servo? I'm running a ProTek.

  7. #7
    RC Competitor
    Join Date
    Jul 2018
    Posts
    90
    Glitch Buster did not work although I left it installed. Can't hurt. I'm just going to leave TSM off for now. Truck and Savox servo work great otherwise.

  8. #8
    RC Competitor
    Join Date
    Jun 2018
    Posts
    88
    Quote Originally Posted by TraxxasTigger View Post
    It does sound like interference - but quite a few use Savox servos. Maybe it's the model Servo? I'm running a ProTek.
    What Pro Tek servo are you running....

  9. #9
    RC Competitor
    Join Date
    Jun 2018
    Posts
    63
    ProTek 155T

  10. #10
    RC Enthusiast
    Join Date
    Apr 2018
    Posts
    20
    Could you ask for a replacement of the 1256 ? Like I said, mine is running great in the UDR, stock ESC.

  11. #11
    RC Competitor
    Join Date
    Jul 2018
    Posts
    90
    Quote Originally Posted by Chuck2001 View Post
    Could you ask for a replacement of the 1256 ?
    Probably, but at this point I'm not convinced it's the servo.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •