Results 1 to 8 of 8
  1. #1
    RC Enthusiast
    Join Date
    Sep 2017
    Location
    Austin, TX
    Posts
    44

    TSM via Blutooth Link and Savox servo acting funny

    Let me explain,
    I have a Savox 1230sg and a CC 10 Amp BEC set at 6.3v on my TRX4, the rest of the electronics are stock. I have been using the Blutooth Link for about a month now and have an odd issue when using the TSM via the app-

    On the app, if i turn the TSM on, even to 1% (It lets you go from 0%-100%) the Savox servo starts acting weird - from a dead stop the steering works fine. However, if move forward at all then stop, turn, center the steering wheel- the wheels remain turned then slowly move back to center. After that i can turn the wheels just fine right or left and it centers immediately. However once i move forward again and steer, the wheels stay in the right or left position (even when the wheel on the tx is centered) for about a second before moving back to center. It happens when going right of left. Its almost like the truck thinks it is moving way fast and is sending a signal to the servo to slow down the steering going back to center to stay in control.

    Now there no issue using the TSM knob on the tx, its only if i select to use it via the Blutooth link app on my phone. If i turn it to 0% on the app the truck runs fine, no steering issues. I'm going to keep it this way.
    I don't even think i need TSM for a crawler, but thought it was odd and was wondering if someone with my setup had a similar issue.

    Ideas?

  2. #2
    RC Competitor
    Join Date
    Jul 2018
    Posts
    90
    Now there no issue using the TSM knob on the tx, its only if i select to use it via the Blutooth link app on my phone.
    I have a Savox SC-1256TG in my UDR and it has similar symptoms. However, in my situation, if I let the Traxxas Link control the TSM, the servo seems OK. If I use the Multifuction knob on the Tx, it acts weird. You may want to take the Rx and EXC updates and recheck.

  3. #3
    RC Racer
    Join Date
    Jul 2018
    Location
    East Detroit
    Posts
    179
    What is TSM?

  4. #4
    RC Racer
    Join Date
    Jul 2018
    Location
    East Detroit
    Posts
    179
    Also what about a Savox would make the function any different in electrical response than any other (cheaper) digital servo.

  5. #5
    RC Competitor
    Join Date
    Jul 2018
    Posts
    90
    What is TSM?
    Traxxas Stability Management

  6. #6
    RC Competitor
    Join Date
    Jul 2018
    Posts
    90
    ...what about a Savox would make the function any different...
    Good question. Lot's of guys are running Savox without incident, but I still think they interact with the TSM differently than the stock 2075X does.
    Last edited by TraxxasTyro; 08-12-2018 at 01:39 PM.

  7. #7
    RC Enthusiast
    Join Date
    Sep 2017
    Location
    Austin, TX
    Posts
    44
    Quote Originally Posted by TraxxasTyro View Post
    I have a Savox SC-1256TG in my UDR and it has similar symptoms. However, in my situation, if I let the Traxxas Link control the TSM, the servo seems OK. If I use the Multifuction knob on the Tx, it acts weird. You may want to take the Rx and EXC updates and recheck.
    Yeah I tried adjusting the TSM from Bluetooth only, then the knob, checked for updates (everything is up to date) and its still acting weird. Tried resetting tx and rx too.

    I have to turn my phone on and turn on the Traxxas link app every time I use my rig otherwise the steering acts up. Once it’s linked up the rig runs fine (cruise control was somehow lost - I still can’t get it back even pressing menu for 3 sec, set, 9 blinks, set protocol). If I turn it off for 10 minutes the settings are still all good, no issues but if I try again the next day it’s acting all funny again. I basically HAVE to bring my phone with me if I want to run this rig which is kind of annoying (1st world problems).

    I think it may be the tx/rx/blutooth. I’ll just keep running as is instead of throwing money at parts that may or may not solve the problem. If any new electronic issues arise I’m dumping the Traxxas electronics and going with something else.

  8. #8
    RC Enthusiast
    Join Date
    Aug 2018
    Posts
    22
    I just started having this problem and I'm glad you got it dialed down to the TSM. I have a brand new Servox 0231MG with a Hobbywing 1080.

    For me it all started when I tried going through all the calibrations for end points and other settings on the Rx. Well for some reason I can't for the life of me dial in the end points on this servo. When I press set to lock in one of the endpoints the servo goes full blast to that direction and turning the other way has very little travel. I ended up resetting the end points and using the dual rate setting to dial it back.

    Well somewhere along that process I wanted to make sure TSM was off. From what I see the only way to do so is by choosing it for the multifunciton dial and turning it all the way down, then switching the dial back to cruise or whatever.

    Well I thought I did that but now when I power up the truck the steering servo is all glitching out. At first I thought it was some sort of interference seeing how it seems a bit random. What happens is just like you described. It really only starts quirking out when I have input on the throttle. It gets all jumpy, doesn't want to straighten, turns on it's own, you name it.

    Is there any other way to make sure TSM is 100% disabled? I thought about resetting factory defaults from the transmitter but so far it isn't acting up anymore. Very interesting to say the least but good to know I'm not blowing through yet another steering servo. This thing does chatter like a mother though.
    Last edited by TMoney128; 08-13-2018 at 12:07 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •