Results 1 to 6 of 6
  1. #1
    RC poster
    Join Date
    Aug 2018
    Posts
    4

    Angry Aton signal trouble

    Hello guys i'm having a problem with Aton to start all batteries are new(TX) and fully charged (RX) with the latest firmware and I can fly my drone for about 2 minutes only five feet away from me just hovering in film mode, note i'm not using my go pro at the moment the RTH will just start and I can't stop it with the air brake option it just lands. On the remote the green lights go out and the battery indicator on the right disappears and on the drone the power light is blinking fast. The drone also seems to take longer to connect (4 solid lights) I never fly it in sport or expert mode.


    Not sure what to do.....

  2. #2
    RC Qualifier
    Join Date
    Feb 2016
    Posts
    910
    Call Traxxas support , I'm sure they will help you out 888 872 9927

  3. #3
    RC poster
    Join Date
    Aug 2018
    Posts
    1
    Did you manage to resolve this?

  4. #4
    RC poster
    Join Date
    Aug 2018
    Posts
    4

    Thumbs down

    Quote Originally Posted by Elot View Post
    Did you manage to resolve this?
    No Traxxas wants me to send it in

  5. #5
    RC Qualifier
    Join Date
    Feb 2016
    Posts
    910
    Do it , Its the best way to get it working correctly

  6. #6
    RC poster
    Join Date
    Aug 2018
    Posts
    3
    Quote Originally Posted by jaystevenson77 View Post
    No Traxxas wants me to send it in
    Did you send it in? Curious to know what they found wrong???

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •