Results 1 to 13 of 13
  1. #1
    RC poster
    Join Date
    Jan 2017
    Posts
    4

    UDR light kit issue

    I just installed the new Traxxas UDR lightkit and I'm having an issue with the Traxxas link app. When i try to use the light function on the app I'm getting a message "no Traxxas power amplifier detected". Everythings been updated , reinstalled the app on my phone (iphone X) , and restarted my phone. The lights work without the app and will cycle through the modes. Has anyone else had this issue?
    Thanks

  2. #2
    RC poster
    Join Date
    Apr 2002
    Posts
    4
    Im having the same issue with the traxxas 8029 kit on a trx-4. Anyone solve this?

    Im all updated on a 6s iphone. The lighting kit is plugged into the spare channel 1.

  3. #3
    Traxxas Employee
    Join Date
    Nov 2013
    Posts
    42
    The #8029 TRX-4 light kit does not work with the #6590 High-Voltage Power Amplifier and the Traxxas Link App.

    On the UDR light kit #8485, the #6590 power amplifier talks to the app through the VXL6Sv2 ESC and the Traxxas TQi radio system.

  4. #4
    RC Competitor
    Join Date
    May 2018
    Posts
    96
    that doesn't help us who have no Traxxas power amplifier detected in the app, my lights worked fine before, now they say that when I go to light part of the app..

  5. #5
    RC Competitor
    Join Date
    May 2018
    Posts
    96
    well, i tried out something, i took off the body, powered on the truck, hit the button on the light kit amp, lights came on.
    I then could turn the lights on and off using the app for when it's day time. So i see now that if u turn off the amp with the little button on top, it will say there is no amp detected. So make sure you have it on, then use the app to turn off the lights for daytime running, if you are wanting to save on batt time.

  6. #6
    RC poster
    Join Date
    Jan 2019
    Posts
    5
    I had the same issue, after trying to update my power amp burned out. I took my truck to traxxas and they replaced my transmitter and power amp for free. now it all works as it should.

  7. #7
    RC poster
    Join Date
    Feb 2019
    Posts
    1
    My issue is the light kit worked fine after fitting, updating and then updated again and now i have no brake lights. The red lights come on when cycled but not when braking. Not sure what has happened

  8. #8
    RC Competitor
    Join Date
    Sep 2018
    Location
    UK
    Posts
    70
    I’ve got the same issue, did anyone find a fix?


  9. #9
    RC poster
    Join Date
    Feb 2020
    Posts
    4
    I had the same issue. I have been using the Telemetry Expander 2.0 for a while now, and I added the Power Amplifier (7885) to my X-Maxx.

    I would be interested to hear whether other posters in this threat have also been using the Expander alongside the Power Amplifier.

    Anyway. It may be a firmware issue or maybe it's how it is supposed to work when you use both the Telemetry Expander 2.0 and the Power Amplifier.

    The solution (for me at least) was to purchase part #6565 (data link cable) and then connect the communication port of the Expander to the Power Amplifier rather than to the Receiver. I attach the instruction sheet that comes with 6565. And it seems I still have all the normal functionality (RPM, volts, temp, GPS, etc) even though the Expander is kind of plugged into the Receiver in a roundabout way now.

    At least, this worked for me.

    PS there is another very similar but different part #6566, which is used to connect the Expander directly to the ESC. Obviously this one will not work here because the power amplifier plugs into the ESC. So make sure you get 6565 not 6566.

    Sent from my SM-G975F using Tapatalk

  10. #10
    RC Enthusiast
    Join Date
    Mar 2020
    Posts
    28
    My truck came with the light kit installed from factory. It works just about 100% of the time. Sometimes I do get the message on the picture above that the amplifier is not present, to fix it, I usually just pull the battery and plug it back in. On another topic, I'm curious about the telemetry expander. Why would any one get this? I have all the same data available on the dashboard without it. Granted the speed and rpm may not be as accurate, but does that really matter? I would like some extra temperature probes, but the receiver has a spot for that. Not dissing anyone that has it. Genuinely curious on what it actually adds.

  11. #11
    RC poster
    Join Date
    Feb 2020
    Posts
    4
    Quote Originally Posted by Light1984 View Post
    My truck came with the light kit installed from factory. It works just about 100% of the time. Sometimes I do get the message on the picture above that the amplifier is not present, to fix it, I usually just pull the battery and plug it back in. On another topic, I'm curious about the telemetry expander. Why would any one get this? I have all the same data available on the dashboard without it. Granted the speed and rpm may not be as accurate, but does that really matter? I would like some extra temperature probes, but the receiver has a spot for that. Not dissing anyone that has it. Genuinely curious on what it actually adds.
    So I started to reply to your question and then realised it is a whole big discussion that may justify a separate thread. So I made one. Enjoy the read.

    The short answer is that you want the Expander if you want GPS or more sensors than just 1xtemp and 1xvolt and RPM.

  12. #12
    RC Enthusiast
    Join Date
    Mar 2020
    Posts
    28
    Read through the other thread. Great job. Thank you

  13. #13
    RC poster
    Join Date
    May 2020
    Posts
    1
    Thank you plofstof! Your instructions of using cable part #6565 (data link cable) connected from the power amplifier to the telemeter expander 2.0 on slot 4 as viewed from your screen shot and the main power amplifier cable connected to the ESC worked perfect! Now the Traxxas Link app gives me the option of turning on and off my front and rear lights. Thank you my friend!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •