Results 1 to 11 of 11
  1. #1
    RC poster
    Join Date
    Sep 2018
    Posts
    3

    Self-Righting INOP

    Hey guys, my story is as follows.

    Bought an E-Revo 2.0 about a month ago. Spur gear stripped (no big deal), ordered and replaced. As soon as I turned my truck on the ESC blinked all red. Called Traxxas, sent in ESC and they warrantied it. No problem. Plugged in new ESC and the Receiver would not communicate. Called Traxxas, they warrantied the receiver. No problem. Put new receiver in and ESC failed..again. Called Traxxas, I sent the whole truck back and asked to "just fix it" and send it back. Turns out motor shorted and was killing the other parts.

    Got the truck back the other day and everything seems good, except the self righting doesn't work. Like, at all. Doesn't even try to work. I did the re-cal on the ESC and re-paired my transmitter with the receiver. Still nothing. Anyone have any idea??

  2. #2
    RC Champion
    Join Date
    Aug 2012
    Location
    Alberta Canada
    Posts
    1,203
    Dont use self righting... it destroys the RCs I took my traxxas ESC out and put a castle MMX

    Sent from my SM-N950W using Tapatalk

  3. #3
    RC poster
    Join Date
    Sep 2018
    Posts
    3
    Understand. I would only use it if the truck is very far...and in grass. But it is SUPPOSED to work...and it does not

  4. #4
    RC Qualifier Charger Man's Avatar
    Join Date
    Oct 2008
    Location
    Kansas
    Posts
    693
    Quote Originally Posted by Strkd_N_Blwn View Post
    Understand. I would only use it if the truck is very far...and in grass. But it is SUPPOSED to work...and it does not
    Do you have the Bluetooth module in the transmitter? If so use the app and make sure the receiver is set to the new e-revo 2.0 profile. If itís not holding the set button for 3 seconds wonít do anything. Thatís all I can think of.


    Sent from my iPhone using Tapatalk
    115 mph Heavily Moddified Slash 4x4 on 6s

  5. #5
    RC poster
    Join Date
    Sep 2018
    Posts
    3
    No Bluetooth module. I've literally drove this thing 3 times before all the problems. The feature worked before I sent it in for repair, now it does not. This is basic, out of the box, no mods, no add ons...nothing. Box stock

  6. #6
    RC Champion
    Join Date
    Aug 2012
    Location
    Alberta Canada
    Posts
    1,203
    I know a lot of people having issues with traxxas esc. Especially in the xmaxx, mine so far has been fine but I'll be adding the max6 next spring unless castle makes a new 1/6 scale combo for xmaxx.

    Even my 1/16 erevo I found the velinion annoying and added a sidewinder. It sucks the ESC's have these odd failures. The rest of the models have top shelf quality. I like the plastic traxxas used it feels like PP66 with 35%GF in the grey plastic at least, some of the black i think is just nylon with no GF

    Sent from my SM-T820 using Tapatalk

  7. #7
    RC Turnbuckle Jr. mwe-maxxowner's Avatar
    Join Date
    Feb 2004
    Location
    pageland, sc(south of monroe)
    Posts
    5,723
    I have a first gen xmaxx I bought used that I have not been able to get self righting to work for either. I have the Bluetooth module and it's programmed and recognized as an xmaxx in the traxxas app. I gave up and just do the walk of shame. Lol. I do wish it would work sometimes.

    Sent from my Moto G (5) Plus using Tapatalk
    460, straightpipes, buried throttle, nuff said :D

  8. #8
    RC poster
    Join Date
    Apr 2018
    Posts
    1
    after 5 months, used it "1" one time, "1".. and it destroyed the cush drive completely , whats up with that?

  9. #9
    Marshal ksb51rl's Avatar
    Join Date
    Nov 2006
    Location
    Northern NJ
    Posts
    20,529
    Quote Originally Posted by jarrodlaws View Post
    after 5 months, used it "1" one time, "1".. and it destroyed the cush drive completely , whats up with that?
    No real question asked.
    No advice given.
    Posted again in the wrong forum.
    Posted for the fourth time.
    It sure seems like all you want is to complain.
    I suggest that before you post the same thing for the fifth through eighth time, you have an actual question, you ask it in the correct section, and you only do it once.
    Alt-248 on the number pad = į

  10. #10
    RC poster
    Join Date
    Sep 2018
    Posts
    6
    I am experiencing this same issue as well. What probably happened is they went in and "re-flashed" the reciever or ESC and is no longer on the most current firmware. They had me send in my transmitter, bluetooth module and reciever today so we shall see what happens. I've only had mine for about 3 weeks as well.

  11. #11
    RC Racer
    Join Date
    Oct 2017
    Location
    IL
    Posts
    108
    Try recalibrating the ESC with fully charged batteries. Had something similar happen and this is what fixed it for me. I use self righting all if the time and have yet to have a problem. I am willing to bet more people have success with it than failures. Sadly you only hear from the people who have failures. You do have to be smart about using it though. When you do use it try to only use it on fairly flat ground. If it doesn't work after three or four try's then it's time for the walk of shame.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •