Results 1 to 9 of 9
  1. #1
    RC Qualifier
    Join Date
    Nov 2016
    Location
    Atlanta, Georgia
    Posts
    943

    Please help! Mmm needs work!

    Hello! I have a Mamba Monster 1 that died today. Was in a hobao car for a long time. Absolutely fantastic esc but it finally stopped giving power to the motor a few runs ago. It still powers steering. Also the fan is toast. Hereís a picture

    Iíll start with cleaning it. Can I use brake/ carb cleaner?


    Sent from my iPhone using Tapatalk

    Edit: these original MMMís are becoming scarce and I will do anything to keep this one on the road.
    Last edited by Peeeenuuutt; 11-26-2018 at 05:02 PM.

  2. #2
    RC Qualifier
    Join Date
    Oct 2015
    Posts
    948
    Is the area that is near the orange wire's solder connection burnt or is that dirt?
    Catch my videos at youtube.com/c/offworkhours

  3. #3
    RC Qualifier
    Join Date
    Nov 2016
    Location
    Atlanta, Georgia
    Posts
    943
    It was some sort of acid. I was able to rub it right off with my fingernail.

    Edit: oh I thought you were talking about the stuff on the motor connector soldering place... thing.... whatever. Anyway that orange wire nah it’s just dirt. I scrubbed it off. There’s still a lot of grime in there and I want it out, so will those cleaners work? Also I forgot to add the fan doesn’t work. It has a weird connector so does anyone know were I can buy a replacement?

    Edit 2: never mind about the fan. The stock ones useless anyway because I’m pretty sure it doesn’t kick in until the things super hot (which is dumb lol) I’ll just get one that plugs into the receiver.
    Last edited by Peeeenuuutt; 11-26-2018 at 05:06 PM.

  4. #4
    RC Qualifier
    Join Date
    Nov 2016
    Location
    Atlanta, Georgia
    Posts
    943
    Could it be a programming issue??? There’s no lights that flash at all. But the steering works. Also no beeps.

  5. #5
    RC Qualifier
    Join Date
    Apr 2018
    Posts
    939

    Please help! Mmm needs work!

    Donít use carb cleaner or brake cleaner!!! Get some electronics cleaner. Repeat, donít use carb or brake cleaner!! Youíll ruin the circuit board!!

  6. #6
    RC Qualifier
    Join Date
    Apr 2018
    Posts
    939
    This is what you want to clean the circuit board. Hopefully we arenít too late.

  7. #7
    RC Qualifier
    Join Date
    Dec 2017
    Location
    Van. Island British Columbia
    Posts
    849
    If you do get that esc working try some of this, I've been using it on all of our electronics that we rc with and we haven't had any issues. Just brush on 2 or 3 layers and your good to go.
    https://www.amazon.ca/dp/B07B8RY7M6/...v_ov_lig_dp_it

  8. #8
    RC Qualifier
    Join Date
    Nov 2016
    Location
    Atlanta, Georgia
    Posts
    943
    You’re not too late and I’m aware that’s what you use but I don’t have any. Guess I’ll buy some

  9. #9
    RC Qualifier
    Join Date
    Nov 2016
    Location
    Atlanta, Georgia
    Posts
    943
    My castle link broke. I’ll buy a new one and test if it’s programming.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •