Results 1 to 8 of 8
  1. #1
    RC poster
    Join Date
    Feb 2018
    Posts
    16

    Low Voltage Cutoff on 2.0 ESC

    My low voltage cutoff seems to be kicking in too early. It happens when I am full throttle for long bursts. If I restart the stock ESC, I still have quite a bit of drive time and power left in the SMC lipos. LVC just seems to kick in before it should.... Anyone else experience this? Any solutions? Ideas to try? Thoughts?

    Could I set the ESC off of Lipo mode and just use a Low Voltage alarm on the lipos?
    Last edited by KirkHayesRevo; 10-27-2018 at 09:44 AM.

  2. #2
    RC Champion FnFancy's Avatar
    Join Date
    May 2016
    Location
    Los Al California
    Posts
    1,658
    If the lvc is kicking in it means the batteries voltage has dropped below the set level. Turning off and back on your esc to get it to run again is not a good idea! This truck asks a lot from batteries, what your seeing is voltage sag. What smc batteries are you using? Turning off lipo mode and running an alarm will yield the same results. What voltage is in the batteries when lvc kicks on?

    Sent from my SM-N960U using Tapatalk
    Its alright son I'll fix it when you break it

  3. #3
    RC Champion
    Join Date
    Jun 2015
    Location
    Brossard, QC
    Posts
    1,211
    If it happens only when you keep full throttle, then your batteries are either done for or they don't provide enough current to sustain the draw

    Sent from my CLT-L04 using Tapatalk

  4. #4
    RC poster
    Join Date
    Feb 2018
    Posts
    16
    Yep...full throttle only for a long punch. I suspect my SMC (which are not very old) have pooped out. The 2nd cell of each is lipo is weak on voltage and Mah during charging. I notice almost overnight I was getting about 30% less runtime out of them for no obvious reason. SMC was not of much help when contacting them. They are 8 months old with about 30 charges on them. oh well.

  5. #5
    RC Champion
    Join Date
    Jun 2015
    Location
    Brossard, QC
    Posts
    1,211
    People are losing faith in SMC here as well.

    Sent from my CLT-L04 using Tapatalk

  6. #6
    RC poster
    Join Date
    Feb 2018
    Posts
    16
    Quote Originally Posted by IllusionX View Post
    People are losing faith in SMC here as well.

    Sent from my CLT-L04 using Tapatalk
    Ya, I won't buy another set of SMCs... They were great for about 25 runs...then all of a sudden, lost their punch and 30% of their capacity. They are the 7200mah ones....and I am lucky to get 5000mah out of them in any of my cars. So I know it is the lipos. Darn things cost $127 shipped.

  7. #7
    RC poster
    Join Date
    May 2018
    Posts
    3
    Are you running 2S or 3S SMCs?


    Sent from my iPhone using Tapatalk

  8. #8
    RC poster
    Join Date
    Feb 2018
    Posts
    16
    Quote Originally Posted by dan3949 View Post
    Are you running 2S or 3S SMCs?


    Sent from my iPhone using Tapatalk
    3S SMC 7200mah.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •