Results 1 to 3 of 3
  1. #1
    RC Champion fourdub's Avatar
    Join Date
    Jan 2016
    Location
    Colton, Inland Empire, Southern California
    Posts
    1,868

    Bad motor claims new ESC :(

    So me and my friend have been running latrax prerunners.

    We had one of the brushed motors seize on us. swapped to a new one, and that new one only lasted a few days.

    Come to found out the ESC is faulty. If the battery is connected, there is power passing thru the motor lead's and causes a load to be placed on the motor, and as the load sits it heats up and cooks the motor.

    We found this out, after removing the 2nd burnt out motor, than when we connected a new 3rd motor, the pinion just started spinning by itself. Even tho all the lights on the truck and the controller are off, power was still being sent to the motor.

    We tried another motor and found it to be doing the same thing.

    We put a new ESC on the truck, and re-hooked up the 2nd burnt motor. (didnt finish swaping it out first I guess). the new esc didnt make the motor move, so we turned it on, and on throttle input the esc popped very loudly and let out the magic smoke.

    So we lost 2 esc's and 2 motors so far.

    Going to call traxxas tomorrow and hope for some help on some replacement parts.

    Sad panda, when you show up to run cars at the track, and you kill two cars worth of electronics.

    got old Tamiya (molex) plug latrax esc's to modify for now. keep us going. and e-flite helicopter brushed motors lol.
    Sla2hvxl,pe4evxl,erevobl
    "Richard Chilson"youtube

  2. #2
    RC Enthusiast
    Join Date
    Jan 2017
    Location
    Eastern Montana, USA
    Posts
    42
    Think this was a one off? Or something to keep an eye on?
    Every crash/ broken story: This one time...

  3. #3
    RC Champion fourdub's Avatar
    Join Date
    Jan 2016
    Location
    Colton, Inland Empire, Southern California
    Posts
    1,868
    Just a weird thing. only way to check is to move the motor from the truck while its still connected to the esc. So its more like a tip, than a warning. lol.

    make sure the draintrain is free rolling before applying any throttle. if the motor is locked, it will pop the esc. hehe.

    my other prerunner is still on the first brushed motor, and been running nothing but 2s lipo thru it.
    Sla2hvxl,pe4evxl,erevobl
    "Richard Chilson"youtube

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •