Results 1 to 2 of 2

Thread: Slayer Problems

  1. #1
    RC poster
    Join Date
    Oct 2018
    Posts
    1

    Unhappy Slayer Problems

    Sorry if I'm putting in wrong section,have read and read posts but my 1st time writing!I have a used slayer pro,is really clean.ordered fuel and while waiting i figured would clean carb. And lines,when I took carb. off I noticed loose cb w no eclip and missing 1 bearing and from what I've read it prob exploded.after pulling engine noticed spring laying under cb was half broke in 1spot.I took off cb,screw that holds flywheel and cone @this point crankshaft was turning ok.w carb pulled i put wd 40 intake and pulled glow plug and sprayed some in top off engine.crankshaft turned a bit then stopped?did I cause a vac type lock?I bought 2 used traxxas nitro trucks cpl yrs ago that ended up having rusted engines besides working on those reading alot ,I'm new to nitro?thanks for any help,and sorry for long post.thanks
    Last edited by Love2learnRc; 11-19-2018 at 05:12 AM.

  2. #2
    Marshal Double G's Avatar
    Join Date
    May 2008
    Posts
    13,500
    If you had the glow plug out you could not hydro-lock the engine. It is very difficult to spin the engine over by just the crankshaft through top dead center and this is due to the design of the sleeve which is tapered at the top.
    Sounds like you need a new clutch, bearings, washer and e-clip. While the clutch bell is off clean it up with some very fine (800 grit or higher) sand paper and flush clean. Then reinstall.
    The Super Derecho

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •