Results 1 to 10 of 10
  1. #1
    RC poster
    Join Date
    Nov 2018
    Posts
    7

    HELP! Installing MMX

    I'm not sure, but I think I blow out my TQI receiver (6518), because I hooked up the MMX plug backwards and I want to confirm. The servos still works, but I can't configure the ESC.

    white-----aux

    brown----negative
    red-------positive
    orange---signal

    Initially I had the negative and signal wires REVERSED!

  2. #2
    RC Qualifier
    Join Date
    Apr 2018
    Posts
    913
    You may have fried it. Best bet is to just get another one and try again. Not worth messing about with it as the components are just so small.

  3. #3
    RC poster
    Join Date
    Nov 2018
    Posts
    7
    Quote Originally Posted by 222 View Post
    You may have fried it. Best bet is to just get another one and try again. Not worth messing about with it as the components are just so small.
    Thanks for the quick reply! Yeah, as soon as I thought it was the receiver, I ordered one. Just checking to see if my 2nd wiring is correct...

  4. #4
    RC Qualifier
    Join Date
    Dec 2017
    Location
    Van. Island British Columbia
    Posts
    849
    Yes your second wiring looks correct.

  5. #5
    RC poster
    Join Date
    Nov 2018
    Posts
    7
    Quote Originally Posted by Rain Dawg View Post
    Yes your second wiring looks correct.
    Thanks Rain Dawg! Maybe it's just me, but the Monster X Driver's Ed Guide is soooo confusing! I see multiple pictures pointing at the brown wire, calling it the rx wire, which means, the whole ribbon cable goes to the rx. And a few pages in, it says, RX Wire (Orange/Red/Brown), but actually it should say, Yellow/Orange/Brown! Also if they marked the connectors ~ + -, I know I wouldn't of made this mistake... Sorry, just venting...

  6. #6
    RC Qualifier
    Join Date
    Apr 2018
    Posts
    913
    I totally agree with the labeling. They make these darn connectors with so many different colors that it can be confusing at times to say the least!

  7. #7
    RC Qualifier
    Join Date
    Dec 2017
    Location
    Van. Island British Columbia
    Posts
    849
    Quote Originally Posted by 808Summit View Post
    Thanks Rain Dawg! Maybe it's just me, but the Monster X Driver's Ed Guide is soooo confusing! I see multiple pictures pointing at the brown wire, calling it the rx wire, which means, the whole ribbon cable goes to the rx. And a few pages in, it says, RX Wire (Orange/Red/Brown), but actually it should say, Yellow/Orange/Brown! Also if they marked the connectors ~ + -, I know I wouldn't of made this mistake... Sorry, just venting...
    I hear you. I never understood why Castle didn't just use black (brown) and your not the first or going to be the last who has plugged things in backwards I'm pretty sure most of us have at least once. I might have done it more then a couple myself lol.
    I'm in the habit of taking pic's with my phone for referencing now before I do wiring lol.

  8. #8
    RC Qualifier
    Join Date
    Apr 2018
    Posts
    913

    HELP! Installing MMX

    I totally agree. Seems every company like hitec, JR, castle creations, Traxxas, has there own wiring scheme. At times if you donít reference them you can get yourself into trouble quick! Like Raindawg said, it has happened to most, if not all of us, at one point or another! Taking pics and reading over the manual is the best way to not mess up!!! Good luck and have fun with it!!

  9. #9
    RC poster
    Join Date
    Nov 2018
    Posts
    7
    Thanks to all! My replacement receiver arrived today, and everything is working properly. Just need to clean up my wiring then I'll be good to go.

  10. #10
    RC Qualifier
    Join Date
    Dec 2017
    Location
    Van. Island British Columbia
    Posts
    849
    That's good to hear now you can have some fun.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •