Results 1 to 6 of 6
  1. #1
    RC Competitor
    Join Date
    Oct 2016
    Posts
    64

    Sitting for a year. Now will not arm

    My aton has been sitting for a year. It was operating fine before I put it away. I tried to fly it today, but it won't arm. Fresh batteries in the controller and tried with two different batteries in the quad. When I push the arm button the right side props start to try to spin, but then it just stops. The left side props seem like they try to move, but don't begin to Spin at all. Any ideas from you all to trouble shoot would be appreciated. Thanks

  2. #2
    RC Qualifier
    Join Date
    Oct 2015
    Posts
    921
    Can you spin the motors freely by hand? Did you try calibrating it?
    Catch my videos at youtube.com/c/offworkhours

  3. #3
    RC Qualifier
    Join Date
    Feb 2016
    Posts
    910
    Try giving it a little bit of throttle just as the blades start to spin .. tends to work for me to get them spinning

  4. #4
    RC Competitor
    Join Date
    Oct 2016
    Posts
    64
    Quote Originally Posted by drivejumpfly View Post
    Can you spin the motors freely by hand? Did you try calibrating it?
    Yeah one of the blades definitely does not spin as freely as the others. I just sent an email to traxxas support.

  5. #5
    RC Competitor
    Join Date
    Oct 2016
    Posts
    64
    Ended up sending it in. They replaced the main board an ESC and a motor. So grateful for their excellent customer service. I was ready to pay whatever the charge was, but they didn't bill me. Who does that??????

  6. #6
    RC Qualifier
    Join Date
    Oct 2015
    Posts
    921
    Traxxas is cool like that. As long as you don't lie to them they take care of you.
    Catch my videos at youtube.com/c/offworkhours

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •