Page 2 of 2 FirstFirst 12
Results 41 to 47 of 47
  1. #41
    RC poster
    Join Date
    Nov 2015
    Posts
    2

    TSM update for receiver

    Today they update the Link App which provides a new Transmitter and Receiver firmware. From now on it works fine again.



    Gesendet von iPhone mit Tapatalk

  2. #42
    RC Competitor
    Join Date
    Sep 2012
    Location
    Lincolnshire UK
    Posts
    87
    Ok. Ill have another crack at it again when i get chance and report back. Seems like i'm not the only one having issues.

  3. #43
    RC Qualifier
    Join Date
    Dec 2017
    Location
    Van. Island British Columbia
    Posts
    773
    Quote Originally Posted by pontiacHP View Post
    Hey bud!! I hope all is well! Thatís weird that the update didnít affect all receivers. I lost temp on all four of mine after the update. Yeah itís pretty cold here too. But despite the cold temps, I still manage to get mine hot.
    I sent you a pm.

  4. #44
    RC poster
    Join Date
    Jan 2019
    Posts
    4
    i did the update.
    looks good now

  5. #45
    RC Qualifier
    Join Date
    Dec 2017
    Location
    Van. Island British Columbia
    Posts
    773
    All 5 updated and the temp works but the Brushed Emaxx still shows 2s not 4s and Traxxas support says it'll be fixed shortly.

  6. #46
    RC poster
    Join Date
    Feb 2019
    Posts
    1
    Quote Originally Posted by MovieBuffoon View Post
    I can attest that as counterintuitive as it seems, going into airplane mode then turning on ONLY bluetooth *DOES WORK*.

    My theory is this. Downloading the most current version of Traxxas Link also has the data needed for the update, SO NO ADDITIONAL DATA IS NEEDED. I have no idea why wifi and/or mobile data interferes with the update, maybe some latent code in the current version makes the app try to "phone home" during the update instead of using what its got, i dont know.

    In any case, I'm an IT guy, so I was pretty methodical with this, and it does work.
    I registered here to thank everyone in this thread, especially those with success stories about putting the iphone into airplane mode. My update was stuck in a loop and even after 1 hour of waiting, never made it past a Retry #1. I finally made it through this morning and could not be happier.

    I did want to make sure this was clear because I tried something differently today. I had to put the Iphone into airplane mode BEFORE I started the Traxxas app and update process. I kept putting it into airplane after I had started the update process and it does not work. I know this still doesn't make sense for a lot of reasons, but it did work for me. I always had wifi on before and never have had an issue before.

    Thanks again for this thread and discussion!

  7. #47
    RC poster
    Join Date
    May 2019
    Posts
    1

    Cool Problem with firmware upgrades

    Quote Originally Posted by Ridebonfire View Post
    There is another old thread in the transmitter or receiver forums and then just commented this:

    I know I am reviving an old thread but surprisingly this is the most recent info google displays when searching Bluetooth failure with traxxas TSM receiver update.

    Have a literally 5 day old X Maxx 8s and bought the Bluetooth adapter and turned everything on. Updated the transmitter fine and when it went to the receiving very it kept switching between validating and then barely installing, validating, installing on and on. Tried the above and didnít work. I called Traxxas and they said if it jams up at Receiver then itís 99% a receiver problem and normally they would require me to send in truck but he offered to send me out a new receiver! This is why I love Traxxas. So, am currently awaiting new receiver and will let you know if it works.

    Also I was terrified I bricked the truck as the transmitter inputs would do nothing even after closing the app and all you have to do is force close the app, turn everything off then back on and you can bash away while you wait for receiver or just decide to return Bluetooth module.



    I have put this solution up in a few forums. Havent heard much back.

    The problem you are having with firmware upgrades is a google issue with the app. If you notice in the traxxas link app it asks for the bluetooth permission and location if i remember correctly. However it never asks for storage permissions. This is most likely an oversight from the programmers as it would seem to be a given. On newer versions of android it is not. So to get to the point before you do your firmware upgrade go to the application properties in android, most likely a long press on the app icon then click properties. You can then select permissions and you will more than likely notice that storage is not an enabled permission. Kind of hard to download firmware to the app if it has no permissions. Enable storage restart the app and you should be in business.

    I remember trying the update for about an hour before i had thought to check this. So dont feel bad

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •