Results 1 to 5 of 5
  1. #1
    RC poster
    Join Date
    Feb 2019
    Posts
    2

    Exclamation Help... my revo 3.3 has no low end torque

    I have a revo 3.3 and it sat up for a year or so and I just brung it back out and put a new glow plug and nitro and it fired up but it has absolutely no low end torque at all and Iíve righted and loosened to slipper clutch and messed with the tune and nothing. It has a lot of high end torque just no low end at all it feels like it has a 40 foot boat behind it on huge tires and itís bogged down it just rolls and then gets up to about 5 mph and then takes off as it should. Iím so lost has anyone had this problem to know how to fix it. Thank you in advanced.

  2. #2
    RC poster
    Join Date
    Mar 2018
    Posts
    10
    Make sure the boot on the carb slide is sealed tight and still rubbery. Then also check the carb itself for any air leaks past the needle and seat. If that all checks out I would take the motor off and inspect the crank case for any cracks or holes. If everything passes make sure that the header o-ring is still in tact and soft enough to seal Iíve had o-rings get hard as a rock and cause this problem. Also if EVERYTHING seems to be alright it may be a gummed up exhaust... or the internals for that matter just basically make sure everything is spinning nice and free. It may be tedious chasing the problem but itís worth it before you spend the money for a new engine. Hope this helps!


    Sent from my iPhone using Tapatalk

  3. #3
    Marshal Double G's Avatar
    Join Date
    May 2008
    Posts
    13,502
    New fuel and pressure line? Carb cleaned out? Was it stored properly or just put away wet?
    The Super Derecho

  4. #4
    RC poster
    Join Date
    Feb 2019
    Posts
    2

    Exclamation Tune

    Quote Originally Posted by Double G View Post
    New fuel and pressure line? Carb cleaned out? Was it stored properly or just put away wet?
    Would the tune on the carb have something to do. Because itís 50/50 now when I first crank it up and run it runs good for a couple a seconds but still not 100% then after a couple rips it goes back to acting like Iím towing a boat then revs up and I canít quite tell if itís hitting high gear or just staying in low. And is there a good video anywhere on how to tune a carb because I havenít found one.

  5. #5
    Marshal Double G's Avatar
    Join Date
    May 2008
    Posts
    13,502
    The Super Derecho

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •