Results 1 to 8 of 8

Thread: E-Maxx issues

  1. #1
    RC Competitor
    Join Date
    Dec 2018
    Posts
    56

    E-Maxx issues

    I have posted about my E-Maxx before and the issues it had with the lipo mode not working and frying a battery. I received my new esc and hooked everything up. When I hit the throttle it barely will turn over and you can hear it try to but no such luck. When I touch the leads to the battery directly they both work. Is there possibly something wrong with to were it wont work with the esc and need new motors?

  2. #2
    RC Turnbuckle Jr. ReglarGuy's Avatar
    Join Date
    Feb 2012
    Location
    Eastern Shore, Maryland
    Posts
    3,685
    Take a picture showing your wiring and electronics layout. There are many things that can cause what problem you're having. If doing that would be a pain in the butt for you, you may have to call Traxxas. That way you can have a two way trouble shooting conversation to get to the bottom of your problem.
    Last edited by ReglarGuy; 02-04-2019 at 05:25 AM.
    The ReglarGuy is kid tested and father approved.

  3. #3
    RC Competitor
    Join Date
    Dec 2018
    Posts
    56
    What is the best way to post pictures? I am not really sure on how.

  4. #4
    RC Turnbuckle Jr. ReglarGuy's Avatar
    Join Date
    Feb 2012
    Location
    Eastern Shore, Maryland
    Posts
    3,685
    I use to use Photobucket until they got greedy and wanted an arm and a leg to use their services. Now I use Imgur it's free.
    The ReglarGuy is kid tested and father approved.

  5. #5
    RC poster
    Join Date
    Feb 2019
    Posts
    1
    My e Maxx well it moves but slow I pick it up off the ground it spins slow then boom high speed I drop it and runs good till I let off throttle then barely moves I have evx 2 speed control with tq3 remote anyone know what my problem could be?

  6. #6
    RC Turnbuckle Jr. ReglarGuy's Avatar
    Join Date
    Feb 2012
    Location
    Eastern Shore, Maryland
    Posts
    3,685
    Did you have this problem when you first changed your transmitter and ESC. If not, how long after did you start having your problem.
    The ReglarGuy is kid tested and father approved.

  7. #7
    RC Qualifier
    Join Date
    Apr 2018
    Posts
    746
    Check your motors as well. They may be fried. If you are running the evx-2 and the twin titans or the single 775, make sure your motor is good. Also you can try to recalibrate your esc if you havenít already done so.

  8. #8
    RC Competitor
    Join Date
    Dec 2018
    Posts
    56
    I only changed the esc, I haven't touched the transmitter other then ensuring it was synced and what not.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •