Results 1 to 6 of 6
  1. #1
    RC Enthusiast
    Join Date
    Jan 2019
    Posts
    42

    Anyone know what this is?

    Hey all as you know been building revo 3.3 up with help from here I took it out for a bash last couple of days and got down to cleaning it fully to get back to looking new and noticed this anyone know where it should be car runs still



    Last edited by Double G; 03-13-2019 at 02:26 PM. Reason: merge

  2. #2
    RC Racer
    Join Date
    May 2011
    Posts
    128
    That it the glow plug wire. It is used to start the engine and is not needed to keep it running. Its an inexpensive piece, only a couple bucks to replace

  3. #3
    Marshal Double G's Avatar
    Join Date
    May 2008
    Posts
    13,203
    Two options: replace the wire or spend a few dollars more and get rid of the wire and use an external glow ignitor. Issues with the wire are as shown in the picture and when it gets cut it will ground to the engine causing the glow plug to flame out.
    The Super Derecho

  4. #4
    RC Enthusiast
    Join Date
    Jan 2019
    Posts
    42
    I use the external plug igniter currently but if cold does cut out

  5. #5
    RC Enthusiast
    Join Date
    Jan 2019
    Posts
    42
    I'd rather do the better option as I've put too much time and money into it to want to skip corners if that makes sense I'd rather it be best it can be

  6. #6
    RC Champion olds97_lss's Avatar
    Join Date
    Dec 2003
    Location
    Dekalb, IL
    Posts
    2,192
    The wire does nothing unless your starting it with the ezstarter. I always preffered the external warmer. Then you could warm the plug a few seconds before cranking the engine over. Made for easier starts. Also, I prefer pull-starts... so I usually did away with the entire ez-start anyway.

    If the engine is running and that wire is connected to the plug, grounding it out on the engine does nothing. The glowplug is kept hot by the engine running, not electricity. If that wire is damaged and it's touching the head somewhere that the bare wire makes contact, then you try starting it with the ez-start, then it won't heat.

    Side note, is that an RB engine? I've only seen one of those running in my life, was a screamer of an engine... too bad the guy that had it couldn't tune a harmonica.
    Expert rigging at it's best!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •