Results 1 to 4 of 4
  1. #1
    RC poster
    Join Date
    Mar 2019
    Posts
    1

    Velineon VXL-3s problems

    I was hoping someone could help me out with my vxl-3s.
    When I use a 2s battery or nimh batteries it will work fine. but when I try and use a 3s battery no lights will come on or it wont turn on. Anyone else ever have this problem.
    The 3s battery works fine in my trx4.

  2. #2
    RC poster
    Join Date
    Sep 2018
    Posts
    12
    Mine over heats quick, I swapped the esc for a hobbywing kept the motor and I can run it as long as I want with no shutting down or overheating.


    Sent from my iPhone using Tapatalk

  3. #3
    RC Qualifier
    Join Date
    Mar 2017
    Posts
    271
    Are you switching the ESC from Lipo mode to NIMH mode and back?
    In NIMH mode a 2S lipo might fool the computer into thinking it's got a NIMH in the truck.
    The 3S would likely trip over-voltage protection.
    Running any Lipo in NIMH mode is dangerous as the Low Voltage Cut-off won't save the battery from over-draining. Battery damage or fire can result. Make sure you are switching modes!

  4. #4
    RC poster
    Join Date
    Aug 2019
    Location
    Porto Alegre, Brazil
    Posts
    1
    Hi Guys,
    Anyone can help me with my one?
    . I did a video to explain the problem.
    https://youtu.be/oZ3GvoJrEkY

    Thanks in advance.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •