Results 1 to 5 of 5
  1. #1
    RC poster
    Join Date
    Mar 2019
    Posts
    10

    X-maxx tires problem

    i have noticed there was a ticking on my X-maxx and found out it was the screws on the proline tires hitting the suspension arm i investigated and found that the tires turn more one way than the other.. any way you know how to fix this i put the stock tires back on and that was also rubbing.

  2. #2
    RC Qualifier
    Join Date
    Jun 2017
    Location
    MA
    Posts
    272
    Re-center the server horn. Adjust the center on the remote.

  3. #3
    RC poster
    Join Date
    Mar 2019
    Posts
    10
    Quote Originally Posted by Snowcrossmxz View Post
    Re-center the server horn. Adjust the center on the remote.
    not a problem with the steering remote it drives strait but when u turn the wheel by hand it will go more one way than the other making the wheels rub on the screw that holds the pin in on the arms
    Last edited by FireCat; 03-20-2019 at 12:05 AM.

  4. #4
    Marshal Double G's Avatar
    Join Date
    May 2008
    Posts
    13,960
    If it is turning more one way than the other then it may be a centering/alignment problem. Try as mentioned above.
    The Super Derecho

  5. #5
    RC Qualifier
    Join Date
    Jun 2017
    Location
    MA
    Posts
    272
    Quote Originally Posted by Double G View Post
    If it is turning more one way than the other then it may be a centering/alignment problem. Try as mentioned above.
    to clarify, the servo horn might not be attached to the servo in the center, and because of that it will turn more one way than the other, and because the remote has a center adjustment, you can adjust the servo center so it appears to be straight. the transmitter adjustment will mask the problem, furthermore TSM will adjust the steering so the truck will go straight at speed.

    1) center the adjustment on the remote. & turn off TSM.
    2) with the system on, take the server horn off and recenter it as best as you can, all while the servo is powered up and radio on.
    3) now test the right to left movement.

    if you are still having a problem, there may be something bent, or jammed up in the linkage.
    I would disable the steering rack and check everything and then reassemble.

    I had a bent link on one side of my maxx and didn't really notice it until I took it apart and set it next to the other side to compare.

    if it fixes the problem for movement, drive the truck in a parking lot and verify it goes straight. use the center adjustment on the remote to make it go straight. then turn on TSM after you have set your adjustment



    also just to make sure, verify the rims are not warped, or any of the A-arms up front swell.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •