I have a 4tec VXL 2.0 and I've been trying to install telemetry. Unfortunately, I have a first generation Expander and GPS module. Both of these items have never been installed in a car before. When ever I fire up the LINK app it want's to do a firmware update on the Expander but it can not do it successfully. Anyone have any ideas? I'd hate to have to toss a GPS module.