This just started happening about two days ago.

When I bought my first 2s LiPo last year (new-ish to the R/C world), I purchased a EZ Peak Plus charger to with it. It has worked perfectly until a few days ago when the fan started grinding and hitting against something, and the charging lights were saying that my battery was too high/low voltage, and that it wasn't safe to charge. It would suspend the charging process after 2-5 seconds.

I tried switching modes, from Balance to Fast, Fast to Store, and tried switching the charging rates. I thought I had gotten it to work when I started charging at the Fast setting at 1A, but I bumped the charger, and it went back to "Voltage to High/Low" again.

This is where things get real weird.

I flipped the charger on it's side (settings were on Balanced at 4 amp charging rate) and tried to peek inside through the fan opening area, and I hit the start button, and it started charging with no problems.

No fan noise, no failed charging, no nothing.

It was like new again.

Also, I have a 3s LiPo, and it doesn't give me any problems on the charger, I can plug it in and start charging easily.

Now I really can't keep holding it up while it charges, it isn't practical, and if you guys think it's broken or the battery is broken, I will replace it. I just wanted to ask to see if it was A. Fixable and B. If it could burn the house down.