Results 1 to 5 of 5
  1. #1
    RC poster
    Join Date
    May 2019
    Posts
    3

    Original Revo 2.5 With top qualifier 3 break is gas and gas is break

    I had this truck for years and never let me down but I let it sit for a few years after this problem started. when I pull the trigger back it gives me brake and I press it forward and I get throttle. after I took it from the Dungan that is my basement the engine was locked up spent hours going though the truck and got it running again. but I still cant figure out why my throttle is backwards. I do not have the manual since I got this truck so long ago and can not find anything online how to fix this using such old gear.

    more info it dose not want to go into reverse and dose not want to shift sometimes but I think that is something that will work itself out as I tune it.

  2. #2
    RC poster
    Join Date
    Feb 2019
    Posts
    7
    First of all check the switches on the radio. Make sure they have not been moved. The ones that reverse the servos. Plus sometimes setting in a basement for years, does damage to the internals of the radio and receiver. I had to swap two radios and receivers to get my original Revo going. Got engine turning over once. Then when trying again it was seized again. Filled it with WD 40 and got it turning over again. Have not started it yet, has been too cold. Though I think its warm enough now.
    Moisture does a lot of damage. Even when you think it's in a dry place

    Sent from my SM-N950U using Tapatalk

  3. #3
    Marshal Double G's Avatar
    Join Date
    May 2008
    Posts
    13,215
    1: Which radio do you have? If the older AM style or the first gen 2.4ghz then you'll need to flip the Ch2 switch on the bottom.

    2: If you have Opti-Drive it will not allow a shift when it senses motion. So your idle may be too high. Or the OD is bad but you could remove it and connect the throttle into Ch2 and reverse servo into Ch3.
    The Super Derecho

  4. #4
    RC Racer
    Join Date
    Dec 2014
    Location
    Adirondacks
    Posts
    136
    Quote Originally Posted by Double G View Post
    1: Which radio do you have? If the older AM style or the first gen 2.4ghz then you'll need to flip the Ch2 switch on the bottom.

    2: If you have Opti-Drive it will not allow a shift when it senses motion. So your idle may be too high. Or the OD is bad but you could remove it and connect the throttle into Ch2 and reverse servo into Ch3.
    +1 Picture of TQ-3 showing location of servo reversing switch
    Switch the one marked CH2
    Last edited by grizzly03; 05-13-2019 at 09:22 AM. Reason: added channel #

  5. #5
    RC poster
    Join Date
    May 2019
    Posts
    3
    Ok so it is the 2.4ghz first gen flipped the switch and it fixed the problem. went out and ran a tank of fuel though the truck and during the time it switched back on me again only did it one time had to flip the Ch2 again. i think it might be time to start to bring this thing up to date. what new type of radio setup would be the best?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •