Results 1 to 7 of 7
  1. #1
    RC Enthusiast
    Join Date
    Dec 2018
    Posts
    32

    E Revo motor temperature

    What is normal operating temp for E Revo? At what temp should I say thatís to hot and turn the car off? If it was ever to get that hot? Does anyone know how accurate is the Traxxas Link app? The motor seems to run pretty hot and was wondering if this is normal or do I look more into this. I just got the hot racing 50mm motor fan and i want to see how much it helps.

  2. #2
    RC Racer
    Join Date
    Feb 2018
    Location
    Maryland
    Posts
    146
    I think someone told me a while back to keep it under 180. The motor temp sensor and the telemetry app are very accurate. I shot the motor with a temp gun one time and the temp gun reading and the traxxas app temp reading was within 2 degrees from each other. The only time I’ve ever had mine get close to 180 is when I was doing donuts on the wet pavement for like 10 minutes straight lol

  3. #3
    RC Qualifier
    Join Date
    Oct 2015
    Posts
    906
    The app is pretty good. I like to keep mine under 165 degrees on the app.
    Catch my videos at youtube.com/c/offworkhours

  4. #4
    RC Enthusiast
    Join Date
    Dec 2018
    Posts
    37
    engine temperature and that of the Esc on my application has the same degrees
    what does your application indicate?

    Inviato dal mio SM-A310F utilizzando Tapatalk

  5. #5
    RC Racer
    Join Date
    Dec 2016
    Posts
    195
    That HR fan should definitely help


    Sent from my iPhone using Tapatalk

  6. #6
    RC Racer
    Join Date
    Feb 2018
    Location
    Maryland
    Posts
    146
    Quote Originally Posted by emi202071 View Post
    engine temperature and that of the Esc on my application has the same degrees
    what does your application indicate?

    Inviato dal mio SM-A310F utilizzando Tapatalk
    Did you buy the separate motor temp sensor? If so, mine did that for a while too. I had to change the name of the esc temp gauge in the app and it started working correctly. Also make sure you have both gauges set up correctly.

  7. #7
    RC Enthusiast
    Join Date
    Dec 2018
    Posts
    37
    Quote Originally Posted by justin13703 View Post
    Did you buy the separate motor temp sensor? If so, mine did that for a while too. I had to change the name of the esc temp gauge in the app and it started working correctly. Also make sure you have both gauges set up correctly.
    I bought either 6535 and 6521 sensors
    I renamed the Esc caliber with engine and added another caliber Esc
    What do you mean by properly set calibers?
    Can you post a photo of where you placed the sensor on the engine?

    Inviato dal mio SM-A310F utilizzando Tapatalk

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •