Results 1 to 9 of 9
  1. #1
    RC poster
    Join Date
    May 2019
    Posts
    3

    Power Off issues EREVO Brushless

    I just got my ERevo. Had a great few runs. Now when I power off the button does not work on the ECU. I hold it for a "one count" and the LEDs cycle through and it powers back on. I have seen this issue raised on Youtube. I called Traxxas product support. I explained the problem and "Matt" knew exactly what I was experiencing. Said I have 2 options. 1- send in the ECU to have it looked and or replaced 2- just unplug the battery while it is powered on. I can not believe 2 is a valid option. Taking voltage away that quick is safe? I mean there are 2 batteries. Does it matter that one drops off that quick? Anyone else experience this and do exactly that without issue?

    And I must say the customer service tone from Matt was horrendous. I appreciate he is probable on a phone all day dealing with the same problems day in and out. But a company should not have this tone represent them. I was polite and patient. All I got from him was the opposite.

  2. #2
    RC Racer
    Join Date
    May 2019
    Location
    Michigan
    Posts
    142
    Mine does this as well occasionally. I assumed it was just hot and wanted to the let fan run longer cuz I can usually wait a minute or two and it will shut off. Now that I got a temp gun and the app module I know it wasn't really that hot most likely. I just unplug it manually if the motor and esc are cool according to my lazer gun.

  3. #3
    RC Champion RICK DIZZLE's Avatar
    Join Date
    May 2008
    Location
    Sierra Vista, AZ
    Posts
    1,185
    This has been a known issue w the VXL-6S. Just unplug the batteries vs try to power it off. If you keep trying to power it off at the switch...you could end up in programming mode.

  4. #4
    RC Qualifier
    Join Date
    Jul 2018
    Posts
    332
    Unplugging is no issue and way to go. Should always unplug after running anyways. Batteries are hooked up in series so pulling one breaks the connection.

    Sent from my Pixel 3 XL using Tapatalk

  5. #5
    RC Champion FnFancy's Avatar
    Join Date
    May 2016
    Location
    Los Al California
    Posts
    1,658
    I'll echo most here, just unplug the batteries! And to touch on the customer service note, I've actually dealt with Matt, he was very knowledgeable and helpful. I didn't experience that vibe with him, or any, traxxas customer service employee.

    Sent from my SM-N960U using Tapatalk
    Its alright son I'll fix it when you break it

  6. #6
    RC Racer
    Join Date
    May 2019
    Location
    Michigan
    Posts
    142
    Quote Originally Posted by RICK DIZZLE View Post
    This has been a known issue w the VXL-6S. Just unplug the batteries vs try to power it off. If you keep trying to power it off at the switch...you could end up in programming mode.
    ha, i forgot that happened to me the day I bought it when I was trying to power it off or when I was trying to go to 70/30 neutral. I managed to reverse the throttle so I had 70 reverse when I pulled back and 30 forward when I tried to reverse. That was not fun to try and get sorted out. I hope it never happens again cuz I already forgot how I fixed it.

  7. #7
    RC poster
    Join Date
    May 2019
    Posts
    3
    TY for the guidance. I will proceed with just disconnecting the Battery. Seems I am in good company. I always unplug the batteries. Just did not feel like an unplug of a powered on device was smart.

  8. #8
    RC Competitor
    Join Date
    Apr 2019
    Posts
    50
    I had the same issue. It got sorted out with a firmware update of the esc.

  9. #9
    RC Racer
    Join Date
    May 2019
    Location
    Michigan
    Posts
    142
    Quote Originally Posted by Gurba View Post
    I had the same issue. It got sorted out with a firmware update of the esc.
    now that you mention this, I don't think it has happened since I installed the wireless module and the app, tx, exc, etc all had updates waiting for them. I just got another module for my rustler vxl today and once I finally get my slash 4x4 ultimate rebuilt it will be getting one too. I got my complete sealed front dif from Jenny's today so I should be able to get back to that project tomorrow.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •