Results 1 to 10 of 10
  1. #1
    RC poster
    Join Date
    May 2019
    Posts
    3

    Steering issue on erevo 2.0

    Truck is 2 months old. And every so often I lose steering when going forward. Once I am going in reverse steering works. When it happens I can not seem to undo it. I restart the car, unplug battery and start. It still does not steer in forward. after a few min of tinkering with the controls it recovers. Only once did this happen if full open throttle. I was able to stop. Anyone see an issue with this.

  2. #2
    RC Qualifier
    Join Date
    Jul 2018
    Posts
    359
    Perhaps call Traxxas to talk with them about that...

    Don't think we got any ideas for ya.

    Sent from my Pixel 3 XL using Tapatalk

  3. #3
    RC Racer justin13703's Avatar
    Join Date
    Feb 2018
    Location
    Maryland
    Posts
    204
    Try turning your tsm knob to a different position when it does this

  4. #4
    RC Enthusiast
    Join Date
    Nov 2017
    Location
    Bay Area, CA
    Posts
    28

    Steering Additional Data

    Quote Originally Posted by rockycmt View Post
    Truck is 2 months old. And every so often I lose steering when going forward. Once I am going in reverse steering works. When it happens I can not seem to undo it. I restart the car, unplug battery and start. It still does not steer in forward. after a few min of tinkering with the controls it recovers. Only once did this happen if full open throttle. I was able to stop. Anyone see an issue with this.
    So, in just the last few days I had the same exact experience. Now I had done some upgrades: HR GTR Shock upgrade kit, Integy Front Rockers and new springs all around. I thought maybe, I had inpeded the steering for some reason. But the reverse steering was great as well as standing still, steering was responsive. Only in Forward motion with throttle would my E-Revo 2.0 fail to steer. Now, with patience, I could get it to turn, let's call it coaxing it for mild directional changes.
    The total time looking at it, looking for mistakes, etc. was 1 hour. I gave up, and without doing anything repair wise, the steering was back to normal.

    It would be nice to know a quick way to remedy this, or at the very least, understand what was happening.

    By the way, while troubleshooting I tried multiple dial settings on the TSM and plugged in and out most electronics within that hour of trying. Nothing worked except time. There was no heat as I was just doing some runs up and down the street. And no problems with the mods as well.
    Last edited by Kona76; 06-12-2019 at 06:14 AM. Reason: missing data
    "Lead, follow or get out of the way".

  5. #5
    RC Racer
    Join Date
    Nov 2011
    Location
    New Jersey
    Posts
    244
    I just got a new e revo 2.0 and have the same problem. Did anyone find out what the solution is?

  6. #6
    RC Qualifier
    Join Date
    Feb 2017
    Location
    UK
    Posts
    568
    I had a steering issue problem with my XMAXX - random loss of steering with throttle applied but only when battery packs were starting to run a little low (new Traxxas 4s packs).

    I now run the truck with TSM switched off (knob all the way down) and the problem disappeared. Traxxas informed me TSM can do lots of unpredictable things to a truck so to switch it off - funny that they market it as a big feature when they know it also causes big issues - especially big when you have a truck the size and weight of an XMaxx and suddenly lose steering randomly!!

    I know I'm in the E-Revo forum, but thought it may help with your issue - its worth a test at least....!
    https://www.youtube.com/iftibashir

  7. #7
    RC Racer
    Join Date
    Nov 2011
    Location
    New Jersey
    Posts
    244
    IftiBashir, thanks for your input! I turned the TSM Off and the steering came back when moving forward, in reverse or stationary. Once the steering came back it continued to work even when I turned the TSM On! This is weird! Now I have to run a few times to see what happens.

  8. #8
    RC Racer
    Join Date
    Nov 2011
    Location
    New Jersey
    Posts
    244
    Traxxas Support finally got back to me. They said the TSM feature is located in the Receiver and decided to send me a new Receiver. I'll let you know how things work out.

  9. #9
    RC Qualifier
    Join Date
    Apr 2007
    Location
    Long Island, NY
    Posts
    365
    Quote Originally Posted by rockycmt View Post
    Truck is 2 months old. And every so often I lose steering when going forward. Once I am going in reverse steering works. When it happens I can not seem to undo it. I restart the car, unplug battery and start. It still does not steer in forward. after a few min of tinkering with the controls it recovers. Only once did this happen if full open throttle. I was able to stop. Anyone see an issue with this.
    Call Traxxas same issue they sent me a new RX receiver. And all good-����

  10. #10
    RC Qualifier
    Join Date
    Feb 2017
    Location
    UK
    Posts
    568
    Quote Originally Posted by 06redssr View Post
    Traxxas Support finally got back to me. They said the TSM feature is located in the Receiver and decided to send me a new Receiver. I'll let you know how things work out.
    Awesome.

    I'm tempted to follow the same path as my truck is still under warranty - but then again I don't run with TSM anymore anyways!
    https://www.youtube.com/iftibashir

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •