Results 1 to 2 of 2
  1. #1
    RC poster
    Join Date
    Jun 2019
    Posts
    1

    Needing some “Help”with my pro spec rear shocks on a 2wd slash.

    Good morning GearHeads!

    Has anybody had any issues running the Prospec shocks on the rear 2wd Slash. I can’t seem to get the truck to rebound the A arms back to parallel. It just squat down and stays there. I ordered the upgraded purple super hard springs for the rear shocks and I have to damper the screw all the way to the bottom of the shock tower to just get the truck to sit level ... For as much money as I spent on the shocks it is extremely frustrating. Any advice or direction would be great.

  2. #2
    RC Qualifier Synnergy's Avatar
    Join Date
    Jun 2017
    Location
    Orygun
    Posts
    866
    Hello Filthy Scotsman! Welcome to the forum! I run the prospec shocks on several builds. Here's a trouble shoot:

    1. Unscrew the lower shock mount and make sure the action of the shocks feel smooth...they should be very smooth.
    2. With the shock disconnected at the bottom still, check the action of both a-arms. Will they fall back down after you raise them up? They should.

    There has to be something binding...maybe a deformed rod end or bend rod.

    3. If the rods are not bend and the rod ends allow for some free pivoting, disconnect the rod end at the axle carrier and check out the a-arms. Make sure the a-arms are freely moving.

    Let us know what you find after this assessment.
    MTFBWY

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •