Results 1 to 3 of 3
  1. #1
    RC Enthusiast
    Join Date
    May 2018
    Location
    Canada
    Posts
    21

    Question Traxxas ID Charger Will No Longer Charge Traxxas ID Battery (LIPO)

    I have a battery issue I need help with!

    I posted this in the battery forum as well as here because there seems to be more visitors in this thread. See below.

    Charger: Traxxas EZ-Peak Dual ID (part # 2972)
    Batteries: Traxxas 5000 mAH 3S (11.1v) LIPO ID (part # 2872X)

    Everything is about 14 months old and in good condition. Batteries are not puffed and are in decent physical condition, wires and plug appear good also.

    I used my Traxxas E-Revo 2, batteries and charger without issue. Always balance charging them and using store charge when not in use. I stored both batteries (storage charge) for a few months while I rebuilt my vehicle and added upgrades.

    Now, one battery balance charges fine and the other does not. I get the error code with the top red light solid (4A). I did the troubleshooting according to manual which didn't help (yes, I always plug connectors together fully).

    I used a voltmeter and found the following:

    My good battery, fully charged: 12.5 volts
    Problem battery that won't charge: 7.6 volts


    I am guessing it won't charge because the voltage is too low? Is that correct?

    If so, how do I correct this issue properly?

    Please help!

  2. #2
    RC Qualifier
    Join Date
    Apr 2018
    Posts
    852
    One cell may have gone bad. If you can, check each cell individually. But it sounds like one of your cells is not showing. A 2 cell lipo shows the voltage you are stating. Which means that if you have a 3 cell lipo, one of your cells is not showing or has gone bad. You might want to contact traxxas and see if they will replace it under their warranty.

  3. #3
    RC Enthusiast
    Join Date
    May 2018
    Location
    Canada
    Posts
    21
    222, you are correct. I had the cells individually checked and one of the cells in the 3-cell battery pack had very low voltage. LHS tried bringing the voltage up again but the voltage would drop back down. Battery is basically garbage now after 1 year of use (not even a ton of use). LHS is recycling it.

    I called Traxxas customer support and they said it may be a candidate for their battery exchange program (50% off cost of new battery), but because I live in Canada, the duties, taxes and shipping would basically bring up the cost to near a full price one.

    Blahhh...

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •