Results 1 to 11 of 11

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    RC Enthusiast
    Join Date
    Sep 2013
    Posts
    21

    traxxas transmitter

    can anyone help me get my remote talking to my boat....yes they are both traxxas components, i plug in the batteries and the transmitter goes green and then instantly blinks red and no response from the remote...if i turn the wheel immediately after plugging in the battery the rudder will turn but pretty quickly stops..any thoughts?

  2. #2
    RC Qualifier
    Join Date
    Dec 2017
    Location
    Van. Island British Columbia
    Posts
    847
    If you haven't you could try a factory reset.
    https://www.youtube.com/watch?v=B-qcJUVCc5o&t=1s

    Then try and rebind and see if that fixes the issue, hopefully this works.
    https://www.youtube.com/watch?v=AOL7Jefbfhk

  3. #3
    RC Enthusiast
    Join Date
    Sep 2013
    Posts
    21
    Quote Originally Posted by Rain Dawg View Post
    If you haven't you could try a factory reset.
    https://www.youtube.com/watch?v=B-qcJUVCc5o&t=1s

    Then try and rebind and see if that fixes the issue, hopefully this works.
    https://www.youtube.com/watch?v=AOL7Jefbfhk
    i've done this with no different results. i plug in the boat batteries and the transmitter goes solid green for a split second then a fast red blink.

  4. #4
    RC Qualifier
    Join Date
    Dec 2017
    Location
    Van. Island British Columbia
    Posts
    847
    Quote Originally Posted by dentguy View Post
    i've done this with no different results. i plug in the boat batteries and the transmitter goes solid green for a split second then a fast red blink.
    Have you checked the batteries in your tx and are they installed correctly, not saying you don't know what your doing but things happen to all of us. The only time I have the tx go red or flash red is when my batteries are low.
    Try talking to support if that's not the problem.

  5. #5
    RC Enthusiast
    Join Date
    Sep 2013
    Posts
    21
    Quote Originally Posted by Rain Dawg View Post
    Have you checked the batteries in your tx and are they installed correctly, not saying you don't know what your doing but things happen to all of us. The only time I have the tx go red or flash red is when my batteries are low.
    Try talking to support if that's not the problem.
    i've even replaced the batteries just to be sure. the remote doesn't blink red just the boat...

  6. #6
    RC Qualifier
    Join Date
    Apr 2018
    Posts
    901
    Also have you calibrated the transmitter to the ESC? Not saying itís the issue, but it wonít hurt to do it as well as a reset and rebind. Hope you get it resolved!!

  7. #7
    RC Turnbuckle Jr. ReglarGuy's Avatar
    Join Date
    Feb 2012
    Location
    Eastern Shore, Maryland
    Posts
    4,083
    If I didn't have any luck with resetting my Tx to factory default, no luck with rebinding, and no luck with recalibrating my ESC; my next step would be to disconnect my servo. Sometimes a bad servo can overload the Rx.

    If no daylight doing that, then my next step would be substitution. To do that you're either going to have to go your (LHS), or you're going to have to get your hands on another Tx, RX, and ESC. From there, I'd swop out the Rx first, then the Tx, and then the ESC. Your problem is one of the three.

    It's a good idea (in the future) to either have other vehicles with simular electronic, extra electronics, or testers that will test your electronic components for trouble shooting purposes. I personally have all three, and even though it take time and money to do it, it's worth it. If not, then your only future options will be being dependent on your (LHS) or Traxxas.

    This is a picture of my mock up for trouble shooting purposes.


    Here's a picture of some of the testers you can get for trouble shooting purposes.
    Last edited by ReglarGuy; 07-23-2019 at 03:32 AM.
    The ReglarGuy is kid tested and father approved.

  8. #8
    RC Qualifier
    Join Date
    Apr 2018
    Posts
    901
    Have you tried to recalibrate the ESC? Check the manual on how to perform the calibration of the ESC with the transmitter.

  9. #9
    RC Qualifier
    Join Date
    Dec 2017
    Location
    Van. Island British Columbia
    Posts
    847
    Quote Originally Posted by dentguy View Post
    can anyone help me get my remote talking to my boat....yes they are both traxxas components, i plug in the batteries and the transmitter goes green and then instantly blinks red and no response from the remote...if i turn the wheel immediately after plugging in the battery the rudder will turn but pretty quickly stops..any thoughts?
    Ok so your first post said transmitter so now I'm assuming that was a typo. It's hard to determine or trouble shoot without all the variables.
    Is this is a new boat?
    Did you buy it used?
    Did you replace anything recently?
    My M41 rx always turns RED when I turn my tx on first, so now I plug the batteries in and then turn my tx on and everything lights up green and no more issues. For whatever reason it sounds like the tx is not binding with the rx.
    Here's the compatability chart just incase the rx was swapped and isn't compatible with the tx.
    https://traxxas.com/support/Traxxas-...tibility-Guide
    It could be a faulty rx or make sure the esc wire is in ch2 which is the 3rd slot in the receiver.

  10. #10
    RC Enthusiast
    Join Date
    Sep 2013
    Posts
    21
    Quote Originally Posted by Rain Dawg View Post
    Ok so your first post said transmitter so now I'm assuming that was a typo. It's hard to determine or trouble shoot without all the variables.
    Is this is a new boat?
    Did you buy it used?
    Did you replace anything recently?
    My M41 rx always turns RED when I turn my tx on first, so now I plug the batteries in and then turn my tx on and everything lights up green and no more issues. For whatever reason it sounds like the tx is not binding with the rx.
    Here's the compatability chart just incase the rx was swapped and isn't compatible with the tx.
    https://traxxas.com/support/Traxxas-...tibility-Guide
    It could be a faulty rx or make sure the esc wire is in ch2 which is the 3rd slot in the receiver.
    i bought the boat new but stupid motor went so i replaced it with a leopard 180 and seaking esc v3 installed everything and it all worked just fine time to time it wouldn't bind but a few unplug and plug back in of the boat batteries and it would work..now it just doesn't turn on. the remote is green the boat turns on and is green for a split second then starts a fast blinking red...i don't know the technical terms trans tx rx blah blah sorry not a rc junky bought the boat because i thought it was cool and now i hate it and want to just throw it in the garbage.....

  11. #11
    RC Qualifier
    Join Date
    Dec 2017
    Location
    Van. Island British Columbia
    Posts
    847
    You'll be fine we've all had bad day's, the boats are a blast to run so don't give up. If you have another rc try and bind that transmitter to that rc and try the second transmitter on your boat receiver and see if it binds. If you don't have a second receiver to try you should take it into a local hobby shop near you or just order another receiver. My bet is the receiver is faulty, your local hobby shop should be able to help you with that.
    Don't get discouraged it's a minor issue that can be sorted out, let us know how you make out.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •