Results 1 to 9 of 9
  1. #1
    RC Champion
    Join Date
    Apr 2011
    Posts
    2,088

    Blinking green light issue

    power my vxl up and a blinking green light , nothing works except for the steering?? any suggestions

  2. #2
    Traxxas Employee
    Join Date
    Jan 2011
    Location
    Plano,TX
    Posts
    55
    Try Recalibrating your ESC. Turn on your Transmitter then press and hold down your Ez set button, the light will turn green then red. When it turns red let go of the button. It should flash red once, when it does give it full throttle and then it will flash red twice. When it flashes red twice go all the way in reverse and hold it there. It should start flashing green, when it does let it go back to neutral and then you should be good to go!

  3. #3
    RC Turnbuckle Jr. rjm2519's Avatar
    Join Date
    Feb 2008
    Location
    Fl
    Posts
    3,062
    Could be too high of voltage, I can't remember now what the esc does when it is in over-voltage protection but it seems like that is what it did. Are you using a nimh?
    Donít handicap children by making life easy

  4. #4
    RC Champion
    Join Date
    Apr 2011
    Posts
    2,088
    it was telling me my throtle trim was wrong but it ended up being a toasted battery, everything worked except for forward and rev. new battery and now it works.

  5. #5
    RC Turnbuckle Jr. BaldyDaniels's Avatar
    Join Date
    Feb 2011
    Location
    Rouleau, aka "Dog River", Saskatchewan, Canada
    Posts
    3,269
    Quote Originally Posted by jaman View Post
    it was telling me my throtle trim was wrong but it ended up being a toasted battery, everything worked except for forward and rev. new battery and now it works.
    Flashing green is the incorrect throttle trim warning, but should not come up from a low battery. If you turn the esc off then set the throttle trim to 0, when you turn the esc back on it should be fine. Just don't want to see you toss a battery pack that might still be ok.


    ---
    I am here: http://maps.google.com/maps?ll=50.417704,-104.615973
    - Sent from Dan's iPad using Tapatalk
    Never trust an "Atom", they make up everything.

  6. #6
    RC Champion
    Join Date
    Apr 2011
    Posts
    2,088
    no the pack was melted on the bottom, must have been sending the wrong voltage or something to the vxl, new battery and works like new again,,,well used again i should say

  7. #7
    RC Turnbuckle Jr.
    Join Date
    May 2011
    Location
    Fraser Valley, BC Canada
    Posts
    3,137
    Melted pack, ya I'd say it's done haha.
    I don't have shelf queens, I have bash kings!

  8. #8
    RC Enthusiast
    Join Date
    Dec 2012
    Posts
    46
    old thread but I'm having this issue. Can't reset ESC. Won't do it. turns green then red, blinks red once and then it's off.

  9. #9
    RC poster
    Join Date
    Aug 2019
    Posts
    4
    im having hte same issue

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •