Results 1 to 4 of 4
  1. #1
    RC Qualifier justin13703's Avatar
    Join Date
    Feb 2018
    Location
    Maryland
    Posts
    270

    Couple quick questions, overcurrent and exploding tires

    Yesterday morning I ran the truck around for a couple minutes and had a few issues I wanted to ask about. First of all, as soon as I turned the truck on, ran a 40 or 50ft wheelie on pavement, brought it back down and I had no throttle. Checked the esc and the overcurrent stage 1 light was on. Shut the esc off and turned it back on and it ran fine. Is this a fluke or is there something common I should check? Driveline seems to be fine, everything rolls and spins correctly as it should. Batteries are both traxxas 5000mah 3s. They were both fully charged.

    Next question, a few minutes after that, a friend of mine was running it and had it up on its two side wheels driving around, Iím sure you all know what came next. Front left tire exploded. My question is, is it worth getting ahold of traxxas about this? The truck doesnít have a lot of runtime but is about 6 months old so Iím guessing no. If not does anyone have an extra left side stock wheel and tire laying around they want to sell lol? I donít really want to pay 50 bucks for 2 of them but I guess I will if I have to.

  2. #2
    RC Champion Acidic01's Avatar
    Join Date
    Jul 2018
    Location
    beaverton oregon
    Posts
    1,090
    For the batteries. Depending on how old may call traxxas see under warranty... It's a battery issue. My lectron pros do the same thing. Hit lvc under wot on pavement. They just don't hold up well anymore. They are a year old now. My smc's are way better.

    Tires tend to wear out depending on drive style. I got 2 just laying around but pretty sure sand / silt are in them.



    Sent from my Pixel 3 XL using Tapatalk

  3. #3
    RC Champion Acidic01's Avatar
    Join Date
    Jul 2018
    Location
    beaverton oregon
    Posts
    1,090
    Oh ya check all your battery connectors for corrosion melting and so on. Had issues with that as well.

    Sent from my Pixel 3 XL using Tapatalk

  4. #4
    RC Qualifier justin13703's Avatar
    Join Date
    Feb 2018
    Location
    Maryland
    Posts
    270
    Quote Originally Posted by Acidic01 View Post
    For the batteries. Depending on how old may call traxxas see under warranty... It's a battery issue. My lectron pros do the same thing. Hit lvc under wot on pavement. They just don't hold up well anymore. They are a year old now. My smc's are way better.

    Tires tend to wear out depending on drive style. I got 2 just laying around but pretty sure sand / silt are in them.



    Sent from my Pixel 3 XL using Tapatalk
    Would this be the case for an overcurrent shutdown? It didn’t go into LVC, it was saying overcurrent. I just checked the connectors and everything looks good, contacts are clean and the connections are tight. Thanks for the help by the way

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •