Results 1 to 3 of 3
  1. #1
    RC poster
    Join Date
    Aug 2019
    Location
    UK
    Posts
    2

    Exclamation Help please: Summit getting no power onto the ground?

    My Summit is whining badly with the motor running OK - the pinion and spur gears are engaged and turning fine - I have tried everything with the Slipper nut (looser / tighter) but still it can't get the power being generated into the wheels and move away properly..... if it does it sounds very laboured and is very slow.... sometimes it just stands still and won't move hardly at all.

    What can the experts suggest please? the problem seems to be between the Spur gear and the driveshafts which all seem fine also..... if you manually turn the wheels while holding the vehicle it does turn the gears and the motor ......

    Thanks

  2. #2
    RC Qualifier
    Join Date
    Nov 2018
    Location
    Spokane, WA
    Posts
    349

    Help please: Summit getting no power onto the ground?

    Check your front and rear diffs for stripped gears



    Sent from my iPhone using Tapatalk

  3. #3
    RC poster
    Join Date
    Aug 2019
    Location
    UK
    Posts
    2
    Quote Originally Posted by Overpowerxmaxx View Post
    Check your front and rear diffs for stripped gears



    Sent from my iPhone using Tapatalk
    Thanks I'm gonna tear all that apart next!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •