Results 1 to 8 of 8
  1. #1
    RC poster
    Join Date
    Sep 2019
    Posts
    5

    Trx4 Receiver blinking fast Red as soon as I plug battery

    Hey guys ,

    hope you can help me with my issue .
    I have 2 Traxxas trx4 ( The original and Sport) and this is the first time I have an issue on the original one (other then steering Servo)

    Battery (Traxxas 2 cell Lipo) battery was fully charged.
    As soon as I plug the battery to the Trx4 , the receiver immediately have a solid Red light followed by Blinking Red (did not even turn on ESC)

    I tried everything from Resetting Remote and Attempt the re-link it by following the hard reset procedure (clicking on the receiver reset button ) with no luck

    I tried resetting the ESC also no luck.

    To note that the Receiver red light is coming up and blinking as soon as battery hooked up with ESC still Off .

    I noticed if Remote is off , plug the battery to Trx4 (red receiver LED blinking) then turn on ESC (solid green light with Receiver still blinking) then turn on Remote , The receiver light becomes solid green but still no response to the Remote .

    Made sure that Remote batteries are new (they work with no issue on the Trx4 sport)

    I tried switching channels in the receiver with no luck.
    Couldn't find much on the issue I am having online and Forum (most of them refers to reset and re-link to the Receiver , The only difference with the issue I am having is that the blinking on Receiver LED is happening as soon as I plug battery.

    I tried unplugging the Steering Servo and got the same behavior
    I tried unplugging the motor and got the same behavior

    Any input on what can cause this issue would be greatly appreciated .
    Not sure if I have a bad ESC or what to note that when I turn it on , it has solid green even though the Receiver light keeps blinking (so it looks still good to me)

    Thank you
    Joe

  2. #2
    RC poster
    Join Date
    Sep 2019
    Posts
    5
    Forgot to mention , I am using Savox SW-0231MG Steering servo as the original one stopped working.
    I do not have bec and I used it so many times and was working great no issues .

  3. #3
    RC Turnbuckle Jr. Greatscott's Avatar
    Join Date
    Mar 2004
    Location
    N. Idaho... Da Sticks!
    Posts
    7,555
    Per the manual, fast blinking red on the receiver indicates low voltage/failsafe mode.

    https://traxxas.com/sites/default/fi...-OM-EN-R01.pdf

    (PG 18).

    Are you using the same battery, and is it charged?

    Have you check the RX box and made sure all of the wires are properly seated?
    Submarine Qualified, Chief Inducted, Navy Retired

  4. #4
    RC poster
    Join Date
    Sep 2019
    Posts
    5
    Yes , all this was checked . Battery same and works fine on my trx4 sport.
    Wiring was checked and flipped channels but nothing works .

    Wonder if esc not sending enough voltage to receiver .
    I will test voltage today to see what I have , also will try hooking up my sport esc to feed the receiver and see what happens

  5. #5
    RC poster
    Join Date
    Sep 2019
    Posts
    5
    Ok so I found the issue to be with the esc.
    Now here is what I did:

    Recap that as soon as I connect the battery, the TQI receiver LED is solid red for 3 seconds and then followed by a rapid Red blinking which is an Indication of a low voltage/safe mode mode .

    1) I unplugged all channels from receiver and Unplugged the Motor and connected battery and got same behavior with receiver red led

    Did this to make sure no other servo are causing this
    so now it is between the esc and receiver

    2) connected battery and tested voltage at the pins of the esc output and gave a me reading to 7 v (I am running 2 s lipo battery from traxxas) so reading is correct . Not a matter of Low voltage

    3) Dis-assembeled my trx 4 sport and used its esc to feed the TQI receiver on my trx4 , plugged the battery and no issue . No Red light at all which is what to expect .

    I then turned on my trx4 TQI transmitter and linked it back to the Receiver (following the linking procedure) and i was able to test successfully my steering servo , lock diff servo

    Conclusion --> at this stage , It is all pointing to esc issue to note that the esc is supplying good voltage , The light is steady green when I turn it on and I even calibrated it successfully but still the TQI receiver is detecting something it don't like and gets into low voltage / safe Mode mode .

    Before I go and buy a new esc , is there anything I can do to make sure I reset the esc properly ?
    any advise .

    Thank you
    Joe

  6. #6
    RC Qualifier
    Join Date
    Apr 2018
    Posts
    845
    Make sure your trims are all set to zero. You may have bumped the throttle trim and it may need to be set back to zero for ESC to work correctly. Hope you get it resolved whatever issue is. Good day.

  7. #7
    RC Competitor
    Join Date
    Oct 2007
    Location
    West Palm Beach
    Posts
    97
    My guess is that the Savox servo is either using too much BEC power, or has damaged the BEC circuit in the ESC. If you have a 6v receiver pack, you could plug it in directly to the receiver and see if it powers up. If you are convinced it is the ESC, you are going to have to replace it, might as well upgrade it with something more reliable than the Traxxas 1 amp BEC output. Its a shame they did not spec out more robust BEC in the stock Traxxas ESC. I ended up using the Traxxas BEC upgrade kit with my digital steering servo.

  8. #8
    RC poster
    Join Date
    Sep 2019
    Posts
    5
    Quote Originally Posted by Hobbimaster View Post
    My guess is that the Savox servo is either using too much BEC power, or has damaged the BEC circuit in the ESC. If you have a 6v receiver pack, you could plug it in directly to the receiver and see if it powers up. If you are convinced it is the ESC, you are going to have to replace it, might as well upgrade it with something more reliable than the Traxxas 1 amp BEC output. Its a shame they did not spec out more robust BEC in the stock Traxxas ESC. I ended up using the Traxxas BEC upgrade kit with my digital steering servo.
    Thank you , I think this is exactly what happened . I used my trx4 sport esc and linked it to my trx4 receiver and it worked with no issues . At this stage I think my esc circuit are toast and I will consider getting a more powerful one as I don't want to end up burning another one
    .

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •