Results 1 to 3 of 3
  1. #1
    RC Enthusiast
    Join Date
    May 2016
    Location
    Hedemora
    Posts
    24

    Nitro Sport "Electronic dead" aa batteries boiling

    hi after i made firmwire upgrade and it was completed successfull and starting everything up and take it for a test run and im noticing that throttle stucks few times so i replace the batteries if they was bad but 1 battery did a cracking sound and boiling so i replace all new again and after a few seconds they starts boiling/leak and now everything is dead.. i have install telemetry expander module/gps in it and have tqi bluetooth... im not sure if the telemetry expander module is fault when i turn left or right the telemetry module flash red fast before all was dead
    Traxxas bandit vxl/tsm.
    La trax alias quad.

  2. #2
    Marshal Double G's Avatar
    Join Date
    May 2008
    Posts
    13,502
    Disconnect everything. With transmitter "on" plug the battery into the receiver and turn it on. One at a time plug and test the servos and accessories and see what happens.
    The Super Derecho

  3. #3
    RC Enthusiast
    Join Date
    May 2016
    Location
    Hedemora
    Posts
    24
    thanks all works now the shortcut was probably inside the expandermodule or maybe not works with nitrosport with 4 aa batteries in it
    Traxxas bandit vxl/tsm.
    La trax alias quad.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •