Results 1 to 4 of 4
  1. #1
    RC poster
    Join Date
    Mar 2020
    Posts
    2

    Maxx: One of the back wheel looks does not connect to the Engine

    Hi,

    I purchase Traxxas maxx two month ago and it works great.

    However, last Friday, we find out the one of the back wheel looks does not connect to the Engine

    You can find the video here:

    https://youtu.be/kzs9OgajfoQ

    Could you please tell me what I can do in this case? How may I get some support and video to fix the issue.

    Thanks a lot

  2. #2
    RC Champion
    Join Date
    Mar 2016
    Posts
    1,147
    Remove the diff cover - inspect parts
    Possibly part #8982 has failed
    or #8950 in the manual
    fabricator

  3. #3
    RC poster
    Join Date
    Mar 2020
    Posts
    18
    when similar think happened to me. i had a pin that holds the drive shaft to the diff housing broke. it is a pin with thread at the end.


    Sent from my iPhone using Tapatalk

  4. #4
    RC poster
    Join Date
    Mar 2020
    Posts
    2
    Thanks a lot for the reply from CrazyXMAXX and Cinizter

    It looks the Pin of the drive shaft (part number 8949 from the menu here: https://traxxas.com/explodedviews/Tr...ssion-Assembly ) is gone.

    It looks that it is similar issue as Cinizter. Hi Cinizter, could you please share the experience how you solved the issue? Where did you buy the new pin?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •