Results 1 to 4 of 4
  1. #1
    RC poster
    Join Date
    Oct 2019
    Posts
    1

    What has my kid done ha?

    I have a 4 month old Slasher 4x4 ultimate that my 6 year has really bashed up, it is his though. However, today he had a pretty hard hit wide open against a curb and now I believe something is slipping. When I have pick it up, all four tires spin when pressing the throttle. However, if I push down on it slightly, then it sounds like the motor just spins up but tires do not move. If I move the throttle just a quarter of the way, then it will go, but full throttle it just winds up and barely moves. So it seems something starts to slip when either heavier weight is applied or revved up higher. Any thoughts?

  2. #2
    RC Racer
    Join Date
    Jun 2019
    Posts
    158
    Loose slipper clutch. Pull it out and tighten up the nut


    Sent from my iPhone using Tapatalk

  3. #3
    RC Qualifier
    Join Date
    Dec 2016
    Location
    N Dakota USA
    Posts
    461
    Quote Originally Posted by calebgilmore View Post
    Loose slipper clutch. Pull it out and tighten up the nut


    Sent from my iPhone using Tapatalk
    Either the slipper clutch like he said above, or the pinion gear may be slipping on the shaft. I would check the slipper clutch first though.

  4. #4
    RC Competitor
    Join Date
    Jun 2012
    Posts
    53
    Quote Originally Posted by Dakratfink View Post
    Either the slipper clutch like he said above, or the pinion gear may be slipping on the shaft. I would check the slipper clutch first though.
    Agreed...on both accounts (slipper clutch or pinion)


    Sent from my iPad using Tapatalk Pro

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •