Results 1 to 4 of 4
  1. #1
    RC poster
    Join Date
    Sep 2019

    Castle Mamba Monster Extreme ESC issues (after Traxxas receiver replacement)

    Hi guys
    I 've bought a used Traxxas XO-1 which seems to be from an earlier generation.
    It's receiver did not support TSM. That was the reason to buy and upgrade the car with a new TQi receiver which supports TSM.

    I did unplugged all the cables from the receiver and plugged them in on same slot in the new receiver.
    Traxxas-Link-App did propose firmware update for the TSM -receiver and the TSM- subsystem which I did.

    After successfully updating the receiver (2 updates), I followed the instructions in Traxxas-Link-App and restarted the Transmitter and the Esc.

    The steering channel works fine and also the TSM settings are now settable via the Traxxas-Link_App.

    But now to the Problem with the ESC:
    All 3 LEDS (green,red,yellow) are flashing and it beeps periodically (endless until I'm switching off the esc). There is no reaction from the ESC to throttle movements on the Transmitter.

    I've really checked several times, that I put the cable into the CH2 slot on the Receiver. Pulled it out and plugged in several times. But without an positive effect.

    I found a Documentation of the Mamba Monster 2 ESC (As far as I know i have the Mamba Monster Extreme build in, but the error indication could be similar or the same). There I found a description of Error Codes and they specified, that the ESC is not detecting a valid signal from the receiver.

    How can I check if the signal is correct?
    Is there a configuration in Traxxas Link App for configuring the receiver output (e.g. I maybe should reverse the channels...)?

    Did anybody of you guys had that or similar issue and an idea how to handle that?
    Do I have to put the ESC in a special mode?

    *** UPDATE ***:
    When I replace the receiver with the old one (Without TSM) everything works again!
    The configuration was already unlocked (by the old receiver) should I lock again before I replacing the receiver..?
    It really seems to be an configuration issue and not cable connecting related!
    Last edited by Schlud; 10-15-2019 at 03:15 PM. Reason: Did a trial

  2. #2
    RC Qualifier Charger Man's Avatar
    Join Date
    Oct 2008
    What you need to do is calibrate the esc to the new receiver.
    Follow the steps below:

    Step 1: Start with the transmitter ON, the battery disconnected, and the ESC’s switch in the OFF position (if ESC has a switch).

    Step 2: Plug a battery into your Castle ESC. (NOTE:* If your ESC does not have a switch, hold full throttle on your transmitter before
    plugging in the battery.)

    Step 3: Hold full throttle on the transmitter and turn the ESC’s switch ON. Keep holding full throttle on the transmitter. If all your
    connections are correct, you will hear one multi-toned initialization “ring” from the motor (all tones are played by the ESC vibrating
    the motor).

    STEP 4: After a second or two, the green LED on the ESC will blink rapidly and the motor will “ring” 4 times rapidly in a row
    (accepting the full throttle endpoint). After the green LED flashes and tones, the ESC will blink the red LED. At this point the full
    throttle endpoint has been set within the ESC and now it’s looking for the full brake endpoint (red LED blinking).

    STEP 5: Move the throttle trigger to the full brake position and hold full brake. After a few seconds, the ESC will flash the red LED
    and ring 4 times rapidly (accepting full brake endpoint).

    STEP 6: After accepting the full brake endpoint the ESC will then blink the yellow LED. Now relax the trigger to the neutral
    position. The ESC will now ring 4 times and flash the yellow LED rapidly to accept the neutral position.

    Sent from my iPhone using Tapatalk
    115 mph Heavily Moddified Slash 4x4 on 6s

  3. #3
    RC poster
    Join Date
    Sep 2019
    Hello Charger Man

    I was able to proceed until step3 of your description.

    All the time all 3 LEDS of the ESC are blinking fast and it does a short beep every second

    Holding full throttle and switch-on ESC never started a green-only-blinking sequence.
    I tried to go through your steps but all the Throttle moves never did change a blinking or beeping status.
    Regardles what im doing. I tried to start with full break (if channel would be inverted) but the situation was the same

    When I put back my old TQI Receiver and bind to the transmitter everything works fine again and normal.
    It's really only the case when I'm using the new tqi receiver (with TSM). But i would like to have TSM

    It seems that I'm having bougth an early XO-1 version.
    I only did found same procedures like you described in the internet.
    But I'm not sure if there are different ones for older ESC's.

    My ESC is unlocked for maximal Speed, not sure if I should lock the system using the old receiver first
    and then changing the receiver to the new one.

    But If a receiver would be defect, it should be possible to replace a receiver using an unlocked System...

    What could I try further....?
    Thanks for sharing any Information!

  4. #4
    RC poster
    Join Date
    Sep 2019
    I finally found the reason and procedure which was neccessary , prior to proceed the recommended steps:
    I did need to remove the whole XO-1 configuration in the Traxxas Link Smartphone app.
    Then I did a fresh connect with DLink (Bluetooth) the Transmitter with the Traxxas Link App. And then I was able to run the calibration step by step as proposed. Reason was that i did the first connect with the old receiver, changed it and for some reason the new receiver hat a wrong configuration until it was set from the app again that it belongs to a XO-1 model. Just want to share if someone runs into same Problem :-)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts